Lógica - necesito ayuda en algoritmia

   
Vista:

necesito ayuda en algoritmia

Publicado por victor ferreira (1 intervención) el 04/04/2009 23:22:26
elavorar un programa que permita ingresar la calificacion de los alumnos y contar la cantidad de alumnos aplazados, alumnos regulares y exelentes en general y por sexo.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Lógica
- Cursos de Lógica
- Temas de Lógica
información
Cursos y Temas de Lógica
- Manual de lógica
- El juego de Hintikka de la lógica
- Temas de Programación lógica e I.A.

RE:necesito ayuda en algoritmia

Publicado por Fatima (1 intervención) el 18/06/2009 15:32:48
Aqui va la ayuda, un poco tarde pero espero pueda ayudarte!!

suponirndo que calificacion es de 1 a 5

declaracion de variables
numerico cantidad_alumnos,cantidad_alumnas, cuenta_aplazo, cuenta_aplazof
numerico cuenta_regular, cuenta_regularf, cuenta_excelente,cuenta_excelentef

Inicio
leer(cantidad_alumnos)
leer(cantidad_alunmas)
//CALCULO PARA SEXO MASCULINO
desde cantidad_alumnos=1 hasta n

leer (calificacion)
Si calificacion<=1 entonces
cuenta_aplazo=cuenta_aplazo+1
sino
Si calificacion=2 o calificacion=3 entonces
cuenta_regular=cuenta_regular+1
sino
Si calificacion=4 o calificacion=5 entonces
cuenta_excelente=cuenta_excelente+1
fin si
finsi
fin si
fin desde

//CALCULO PARA SEXO FEMENINO
desde cantidad_alumnas=1 hasta n
leer (calificacion)
Si calificacion<=1 entonces
cuenta_aplazof=cuenta_aplazof+1
sino
Si calificacion=2 o calificacion=3 entonces
cuenta_regularf=cuenta_regularf+1
sino
Si calificacion=4 o calificacion=5 entonces
cuenta_excelentef=cuenta_excelentef+1
fin si
finsi
fin si
fin desde

imprimir ('LA CANTIDAD DE APLAZOS MASCULINOS ES: ', cuenta_aplazo)
imprimir ('LA CANTIDAD DE APLAZOS FEMENINOS ES: ', cuenta_aplazof)
imprimir ('LA CANTIDAD DE REGULARES MASCULINOS ES: ', cuenta_regular)
imprimir ('LA CANTIDAD DE REGULARES FEMENINOS ES: ', cuenta_regularf)
imprimir ('LA CANTIDAD DE EXCELENTES MASCULINOS ES: ', cuenta_excelente)
imprimir ('LA CANTIDAD DE EXCELENTES FEMENINOS ES: ', cuenta_excelentef)
fin
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar