Matlab - problema gráfica matlab

   
Vista:

problema gráfica matlab

Publicado por problema gráfica matlab (2 intervenciones) el 21/01/2011 11:23:19
Necesito crear una grafica

Y el problema es que cuando yo pongo el comando plot() para dibujar un vector en esa grafica, me rescala los ejes y no me permite dejarlos con las medidas que yo quiero:

Eje x:
0, 125,250,500,1000,2000,4000 y 8000

function dibujargrafica2

% las formas de definir los ejes puede se de esta forma:
set(gca, 'YTick', [0 0.05 0.1 0.15 0.2 0.25 0.3 0.35 0.4 0.45 0.5 0.55 0.6 0.65 0.7 0.75 0.8 0.85 0.9 0.95 1]);
set(gca, 'YTickLabel', {'-20','-15', '-10', '-5', '0', '5', '10', '15', '20', '25', '30', '35', '40', '45', '50', '55', '60', '65', '70', '75', '80'});
set(gca, 'XTick', [0 0.143 0.286 0.429 0.572 0.715 0.858 1]);
set(gca, 'XTickLabel', {'0', '125', '250', '500', '1000', '2000', '4000', '8000'});
% o de esta otra forma:
% v=axes('XTick',[0 0.05 0.1 0.2 0.35 0.5 0.7 1], ...
% 'XTickLabel', {'0', '125', '250', '500', '1000', '2000', '4000', '8000' },...
% 'YTick', [0 0.05 0.1 0.15 0.2 0.25 0.3 0.35 0.4 0.45 0.5 0.55 0.6 0.65 0.7 0.75 0.8 0.85 0.9 0.95 1],...
% 'YTickLabel', {'-20','-15', '-10', '-5', '0', '5', '10', '15', '20', '25', '30', '35', '40', '45', '50', '55', '60', '65', '70', '75', '80'});



t=[0 125 250 500 1000 2000 4000 8000];
x=[5 0 5 -5 10 5 -5 10];
plot(t,x, 'Marker', 'x');
ylim([-20 80]); %con esto se vuelve a reescalar los ejes pero la grafica
xlim([0 8000]); % me sale de esta forma
grid on;


Siempre me pone los ejes con 10 divisiones y con el mismo espacio entre ellas y cambia los nombres.
Si no pongo estas dos líneas:
ylim([-20 80]); %con esto se vuelve a reescalar los ejes pero la grafica
xlim([0 8000]); % me sale de esta forma
La grafica me sale con otra gráfica pero no es lo que quiero.

Un saludo y muchas gracias

Julián
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

problema gráfica matlab

Publicado por claudio (1 intervención) el 07/03/2011 19:09:15
Hola Julian,


Resulta que tengo el exactamente el mismo problema tuyo y me ha sacado canas verdes. Al respecto, lo pudiste solucionar??, en caso de ser asi, podrias ayudarme. gracias

Saludos
Claudio
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar