MySQL - base en MySQL se desconecta en segundos

   
Vista:

base en MySQL se desconecta en segundos

Publicado por MOISES RODRIGUEZ MORA (2 intervenciones) el 04/05/2008 01:34:32
Estimados amigos de la Web del programador::: mi problema es el siguiente he trbajado con un sitio PLESK donde se aloja la version 5.x de MySQl y lo trabajo con Visual Foxpro para hacer mis conexiones y nunca he tenido ningún problemo... en estos dias adquiri un sitio en la cual me ofrecieron el MySql 4.1.2 Pero tengo el incoveniente que cuando realizo la cadena de conexión espero unos segundos y ella se pierde por favor si alguien me puede colaborar o si existe alguna forma de configurar el tieempo de conexión o que me diga como hacer para que no se me pierda la conexion en segundos se lo agradezco.

Atte.. MOISES RODRIGUEZ
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:base en MySQL se desconecta en segundos

Publicado por Gonzalo GC (339 intervenciones) el 04/05/2008 04:45:22
Verificá la cadena de conexión. Hay variaciones de parámetros entre versiones de MySQL y entre conectores que se usen.
De hecho, en las versiones del conector .Net 1.X y 5.X, varían en elementos esenciales, así que la cosa puede andar por allí.
El delay que percibes puede deberse al TCP/IP y no a la base (reintentos de comunicación via web).
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:base en MySQL se desconecta en segundos

Publicado por MOISES RODRIGUEZ (2 intervenciones) el 05/05/2008 00:53:52
Gracias amigo Gonzalo.. te agradezco mucho tu atención pero lo que pasa no es que la conexión se piederad por unos segundos... es que al cabo de unos segundos ya no hay conexión se pierde totalmente Te agradezco si sabes algo mas de esto Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:base en MySQL se desconecta en segundos

Publicado por Gonzalo GC (339 intervenciones) el 05/05/2008 02:23:04
Entendí perfectamente el problema, pero hay unas cosas que no me queda claro porque no lo dices en el post:
¿Llegan a producirse transacciones, o se muere la conexión segundos después de abrirse?
¿Verificaste si la conexión tiene un lifetime de duración definida?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar