Open GL - problemas GL_DEPTH_TEST

   
Vista:

problemas GL_DEPTH_TEST

Publicado por Daniel (1 intervención) el 12/12/2008 02:19:44
Hola, les comento mi problema, estoy aprendiendo a programar en OpenGL, y una de mis practicas consistio en hacer una planeta tierra (como si fuera un Google Earth muy modesto), pude hacerlo y que funcione bien, pero cuando se los paso a mis amigos, en otras maquinas que no sean la mia, hay problemas, es como si el GL_DEPTH_TEST no existiera y les muestra todo, incluyendo las caras oculatsa que hay en la escena. Esto paso en todas las maquinas en lo que lo probe que no sea la mia. Alguna idea que pude haber hecho mal? Saludos.

Daniel.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:problemas GL_DEPTH_TEST

Publicado por killito (3 intervenciones) el 21/12/2008 11:08:58
Lo primero que tienes que saber cual es la implementacion que usas tu y la de tus amigos, (la empresa que ha creado el opengl de la maquina, no la version)

Probablemente en la opcion por defecto el dept_test estara activado en tu maquina o desactivado en las demás por lo que solo tendras que poner
GL_Enable(GL_DEPTH_TEST); en el inicio del programa una vez inicializado opengl. Tambien puede ser que al inicializar el modo grafico de opengl no le hayas dicho que vas a usar el buffer de profundidad y se puede inicializar un modo grafico en el que simplemente no hay z-buffer o buffer de profundidad
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar