PHP - error subiendo archivo al servidor

   
Vista:

error subiendo archivo al servidor

Publicado por Kiki (2 intervenciones) el 20/02/2014 14:14:34
tengo este formulario para envíar el archivo, le puse el método get para saber i envía y lo está haciendo
------------------
<html>
<body>

<form action="upload_file.php" method="get"
enctype="multipart/form-data">
<label for="file">Filename:</label>
<input type="file" name="file" id="file"><br>
<input type="submit" name="submit" value="Submit">
</form>

</body>
</html>
---------------------

este es el script para ver lo que se recibe

--------------------------
<?php
if ($_FILES["file"]["error"] > 0)
{
echo "Error: " . $_FILES["file"]["error"] . "<br>";
}
else
{
echo "Upload: " . $_FILES["file"]["name"] . "<br>";
echo "Type: " . $_FILES["file"]["type"] . "<br>";
echo "Size: " . ($_FILES["file"]["size"] / 1024) . " kB<br>";
echo "Stored in: " . $_FILES["file"]["tmp_name"];
}
?>
------------------

esto es lo que se muestra en la página:

Upload:
Type:
Size: 0 kB
Stored in:
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

error subiendo archivo al servidor

Publicado por xve (5518 intervenciones) el 20/02/2014 16:33:22
Hola Kiki, en método get no subirá nunca ningún archivo, ya que permite pasar muy pocos caracteres... tiene que ser en modo post siempre.

Si lo pones en modo post, creo que debería de funcioanr... parece que esta todo correcto.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

error subiendo archivo al servidor

Publicado por Kiki (2 intervenciones) el 26/02/2014 23:53:09
no, ya lo hice con post. El método get lo puse para ver si se estaba enviando algo aunque no sabía que con ese método no se enviaba archivos. Creo que está todo bien que debe ser algún problema de configuración. No se mucho de configurar, yo solo instalo el wamp que incluye un servidor web con apache y mysql y siempre he tabajado sin pensar en la configuración de todo lo que se inatala. Voy a probar reinstalar a ver si resuelvo y luego te digo.

gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar