PHP - Mi web no carga la base de datos, al loguearse varios usuarios

   
Vista:
Imágen de perfil de Gerson

Mi web no carga la base de datos, al loguearse varios usuarios

Publicado por Gerson gersonctk@hotmail.com (3 intervenciones) el 12/09/2014 05:12:36
Estimados

Estoy desesperado ya estoy entrando a este mundo de desarrollo en PHP, ya casi terminando mi web lo colgué en un servidor de pago para probar el media query en distintos tamaños de pantalla y me di la sorpresa que cuando me logueo en una pc para poder modificar o ver los datos de mi usuario si lo logré pero intente entrar desde mi smartphone y cuando me logueo no me carga mis datos de la base de datos e intente desde otra pc y gualmente no carga mis datos al loguearme..


habrá algun problema con las variables de session?

este es mi codigo php de logueo


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
session_start();
include('../conexiones/conexion.php');
 
 
$usuario = mysql_real_escape_string($_POST['txt_usuario']);
$clave = mysql_real_escape_string($_POST['txt_clave']);
 
$sql = mysql_query("SELECT * FROM usuario WHERE BINARY  usuario_usuario ='".$usuario."'  AND BINARY  clave_usuario='".$clave."'");
 
if($row = mysql_fetch_array($sql))
{
 
$_SESSION['id_usuario'] = $row['id_usuario'];
$_SESSION['usuario_usuario'] = $row['usuario_usuario'];
 
$sql_n = mysql_query("SELECT * FROM negocio WHERE id_usuario='".$row['id_usuario']."'");
 
$row_n = mysql_fetch_array($sql_n);
$_SESSION['id_negocio']=$row_n['id_negocio'];
$_SESSION['nombre_negocio']=$row_n['nombre_negocio'];
 
 echo" <SCRIPT LANGUAGE='javascript'>"
          . "		location.href = 'web_admin/';"
          . "		</SCRIPT>"
          ."";
 
 
}
else
{
          echo" <SCRIPT LANGUAGE='javascript'>"
          . "		location.href = 'login_error/los datos ingresados no existen. vuelve a intentar';"
          . "		</SCRIPT>"
          ."";
 
}
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Mi web no carga la base de datos, al loguearse varios usuarios

Publicado por xve (5519 intervenciones) el 12/09/2014 14:18:28
Hola Gerson, tu código lo veo bien, y creo que tendría que funcionar-te en cualquier navegador, a excepción del código javascript...
Yo realizaría las redirecciones con PHP... algo así:

1
header("location:web_admin/");

Coméntanos, ok?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Mi web no carga la base de datos, al loguearse varios usuarios

Publicado por Gonzalo (338 intervenciones) el 12/09/2014 18:31:57
posibles causas:

si tu servidor es una pc pentium estas tienen un limite de conexiones.

si estas usando access entonces si hay 10 usuarios conectados el 11 ya no entra hasta que se libera un canal.

cierra la conexion con la base de datos al terminar el sclipt, tal vez el navegador la deja abierta.

espero sea de ayuda, suerte, salu2.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Gerson Yordy

Mi web no carga la base de datos, al loguearse varios usuarios

Publicado por Gerson Yordy (3 intervenciones) el 12/09/2014 21:54:57
Gracias es muy... logica tu respuesta...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar