PHP - include no funciona

   
Vista:

include no funciona

Publicado por mario mluis12@hotmail.com (17 intervenciones) el 28/02/2015 20:24:16
Hola amigos necesito ayuda, tengo una página web INDEX.PHP la cual en una parte de la misma tiene un include que hasta ayer todo lo hacia bien pero ahora no lo ejecuta, podrian ayudarme y decirme el por qué, no me doy cuenta. os paso como esta el código. muchas gracias.


php
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

include no funciona

Publicado por Manuel Emilio Vargas Herrera (154 intervenciones) el 28/02/2015 20:32:31
Aquí comparto contigo el siguiente enlace: http://php.net/manual/es/function.include.php. Tal vez el error está en que encierras entre paréntesis "guardia.php".
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por mario (17 intervenciones) el 28/02/2015 20:49:28
Hola gracias por contestar, no ese no es el problema, el caso es que no entra en <?php
include 'guardia.php';
y hasta ayer lo hacia perfecto.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por Manuel Emilio Vargas Herrera (154 intervenciones) el 28/02/2015 20:58:18
¿Por qué no pruebas lo siguiente para saber si es que no está entrando en "guardia.php" o si es que está fallando el código fuente en ese archivo?

1
2
3
4
5
<?php
echo "antes";
include "guardia.php";
echo "despues";
?>
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por mario (17 intervenciones) el 28/02/2015 21:13:07
pues si, tienes razón, me imprimió antes y después pero no ejecutó el include guardia.php. te paso el codigo de guardia.php por si me echas una mano. muchisimas gracias.


guardia
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por Manuel Emilio Vargas Herrera (154 intervenciones) el 28/02/2015 21:38:13
¿Por qué no escribes mensajes de "echo" antes y después de cada instrucción para saber dónde está el problema?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por MMan (59 intervenciones) el 28/02/2015 21:15:04
lo cambiaste de carpeta ?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por mario (17 intervenciones) el 28/02/2015 21:22:28
no, guardia.php sigue en la misma carpeta, yo me estoy preguntando si ha habido algún cambio con alguna version nueva de php que ya el include no funcione?.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por mario (17 intervenciones) el 28/02/2015 22:48:09
He entrado en GUARDIA.PHP y he colocado un echo en el IF y otro en el ELSE y los a imprimido correctamente, no se por qué no devuelve al salir del ?> en <li><p><? echo $mensaje ?></p></li> el valor de la variable $mensaje, $imagen.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por Manuel Emilio Vargas Herrera (154 intervenciones) el 28/02/2015 22:57:36
Intenta dos cosas:

1. Quita de "guardia.php" la etiqueta de cierre ?>
2. Coloca los datos en variables session.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por MMan (59 intervenciones) el 28/02/2015 23:01:05
<?php
include "guardia.php";

echo $noche;
echo $dia;
echo $farmacias;
echo $mensaje;
echo $imagen;
echo $codigo;

?>

funciona ??
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por Manuel Emilio Vargas Herrera (154 intervenciones) el 28/02/2015 23:29:47
Prueba sustituyendo
1
<? echo $mensaje ?>
por
1
<?php echo $mensaje ?>
en el archivo PHP donde despliegas los mensajes.

Aquí puedes encontrar la respuesta a tu problema: http://php.net/manual/es/language.basic-syntax.phptags.php
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

include no funciona

Publicado por mario (17 intervenciones) el 01/03/2015 00:53:51
he hecho lo último que me has dicho sustituí <? echo .... por <?php y funciona.

Pero me pregunto el por qué ahora así y ayer todo funcionaba perfectamente.

Pero bueno, gracias a ti he salido de un gran apuro, muchísimas gracias amigo te debo una que no se como pagartela, jajajaj. pero si te enteras o crees saber el por qué de ese cambio te agradezco me lo hagas saber.

de nuevo muchas gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar