PHP - Problema con mySql

   
Vista:

Problema con mySql

Publicado por Gustavo (3 intervenciones) el 18/01/2008 00:11:58
hola ke tal?
Tengo un problema con el mamp.
Instale el mamp en la imac,cuando inicio los servidores voy a la pagina de inicio y funciona bien,
hice una pagina php y funciona bien, pero cuando hago una base de datos desde phpmyadmin y hago la consulta desde el php no me muestra los datos de la base, y no me da error en pantalla,
en el log me aparece este error

Warning: mysql_result() [<a href='function.mysql-result'>function.mysql-result</a>]: Unable to jump to row 0 on MySQL result index 3 in /Applications/MAMP/htdocs/primer_conexion.php on line 15

el php es este:

<html>
<head>
<title>Ejemplo de PHP</title>
</head>
<body>
<?php

$link=mysql_connect("localhost","root"."root");

mysql_select_db("pruebas",$link);

$result = mysql_query("SELECT * FROM noticias", $link);

echo "Nombre: ".mysql_result($result, 0, "nombre")."<br>";

mysql_close($link); //cierra la conexion

?>
</body>
</html>

la base de datos se llama pruebas, la tabla noticias y tiene un solo campo que es nombre y tiene como dato predeterminado "gustavo"

, cuando lo ejecuto en pantalla solo me aparece "Nombre" que es lo que escribe el php.

Alguien puede ayudarme para poder resolver este problema y saber por que no me muestra los datos de la base de datos.
Gracias,Gustavo.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problema con mySql

Publicado por insignia (1 intervención) el 18/01/2008 14:15:50
Si lo copiaste y pegaste tal cual...no vendrá todo de:

$link=mysql_connect("localhost","root"."root");

Ese punto en lugar de coma entre el usuario y contraseña... estas haciendo lo mismo que harías con:

$link=mysql_connect("localhost","rootroot");

A veces el problema está en lo mas simple ;)

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con mySql

Publicado por gustavo (3 intervenciones) el 18/01/2008 22:43:23
hola ke tal, gracias por responder tan rapido, probe eso de cambiar el punto por la coma, pero igual me hace lo mismo, no me muestra los datos de la base, y tampoco me da error.
POr que sera???
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar