SQL Server - Caracteres especiales error !!!!

   
Vista:

Caracteres especiales error !!!!

Publicado por Cristian (12 intervenciones) el 30/12/2009 23:13:20
Hola a todos...
Estoy intentanto guardar en campo memo un texto en html.
Cuando lo guardo en la base de datos directamente funciona, pero cuando lo quiero dar de alta en un formulario me da error por ejemplo en el medio del codigo: 'calibri'.
Si yo le saco todo lo que sea con comillas simples fuciona.. pero no se como hacer porque si lo guardo directo anda... no se porque es... aca pongo una parte de lo que quiero guardar:

<SPAN class=mediumtext><SPAN style="LINE-HEIGHT: 115%; FONT-FAMILY: 'Calibri','sans-serif'; BACKGROUND........

el error esta en 'calibri', sans-serif', y claro le saco las comillas simples y nada... ya no se que mas hacer...

Espero me puedan ayudar... un saludo gracias y feliz año para todos
Cristian
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Caracteres especiales error !!!!

Publicado por Ethan (4 intervenciones) el 12/01/2010 00:14:16
remplaza las comillas por otro caracter utiliza la funcion de replazar en tu app ponle otro caracter k no sea comillas simples
ejemplo

codigo en visual cuando vas a insertar

tucaja.text="<SPAN class=mediumtext><SPAN style="LINE-HEIGHT: 115%; FONT-FAMILY: 'Calibri','sans-serif'; BACKGROUND"

variabletexto=replace(tucaja.text,"'", "$")

tusentenciaSQL="insert into tutabla values (" & variabletexto & ")"

instruncioninsertarenBD(tusentenciaSQL)
'no deberia marcar error

cuando visualices tus datos, los extraigas de la BD

tienes k hacer lo contrario

consultaSQL("select tu datos")

'asi estaria guardado en tu db
tudatos="<SPAN class=mediumtext><SPAN style="LINE-HEIGHT: 115%; FONT-FAMILY: $Calibri$,&sans-serif&; BACKGROUND"

tucaja.text=replace(tudatosDB,"$","'")
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Caracteres especiales error !!!!

Publicado por Cristian (12 intervenciones) el 17/01/2010 18:40:46
Hola Ethan ... gracias por responder....

Lo voy a probar y te cuento... un saludo y gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar