SQL Server - problema con el compute

   
Vista:

problema con el compute

Publicado por simon (1 intervención) el 08/05/2012 12:20:09
Alguien me que me pueda ayudarrr a resolver este problema, explico, de una tabla obtengo mediante un compute en una consulta el valor de la suma , y me sale correctamente y me sale con un nombre de columna "sum" y necesito pasar ese valor a visual studio, generalmente lo hago con el rs("....").value y le pongo el rs("sum").value pero arroja el error que no encuentra el elemento en la coleccion que corresponde con el nombre o el ordinal pedido. alguna solucion?? :S para poder pasar ese valor a visual...
gracia!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Isaias

problema con el compute

Publicado por Isaias (3180 intervenciones) el 08/05/2012 17:22:37
Coloca tu pregunta en el grupo de desarrolladores en VISUAL, existe una buena pagina:

www.elguille.info/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

problema con el compute

Publicado por leonardo_josue (79 intervenciones) el 09/05/2012 18:59:02
Hola Simon:

Estás utilizando algún Alias en el campo calculado? Por el comportamiento que dices creo que no estás utilizando ningún alias, por lo tanto no reconoce la columna sum como parte de la consulta. prueba poner algo como esto:

SUM(.....) total
o
SUM(.....) AS total

donde total es el Alias que asignas al campo (la palabra reservada AS es opcional). De tal manera que en tu código pongas.

rs("total")

Haz la prueba y nos comentas o tal como lo comenta en compañero Isaias, publica tu pregunta en un foro de Visual:

http://www.lawebdelprogramador.com/foros/Visual_Basic/index1.html

Saludos
Leo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar