Tomcat - JBoss no me muestra imágenes

   
Vista:

JBoss no me muestra imágenes

Publicado por Jorge (2 intervenciones) el 18/09/2007 12:34:06
Buenos días,

Tengo un problema con Java. Uso JBoss 3.2.7 y Eclipse. El problema ha sido al combinar JSP y servlets. Inicialmente solo con archivos JSP JBoss iba bien, me mostraba imágenes. El caso es que he tenido que crear un servlet para subir archivos al servidor y ahí es cuando tengo el problema.

Tengo dos versiones del archivo web.xml. En este se ven las imágenes pero no me funciona el servlet:

<?xml version="1.0"?>
<!DOCTYPE web-app PUBLIC
"-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
"http://java.sun.com/dtd/web-app_2_3.dtd">
<web-app>
<display-name>Usuarios</display-name>
<description>Usuarios</description>
<servlet>
<servlet-name>UploadFichero</servlet-name>
<servlet-class>com.devx.example.UploadFichero</servlet-class>
</servlet>
</web-app>

En este me funciona el servlet, pero no me muestra ninguna imagen:

<?xml version="1.0"?>
<!DOCTYPE web-app PUBLIC
"-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
"http://java.sun.com/dtd/web-app_2_3.dtd">
<web-app>
<display-name>Usuarios</display-name>
<description>Usuarios</description>
<servlet>
<servlet-name>UploadFichero</servlet-name>
<servlet-class>com.devx.example.UploadFichero</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>UploadFichero</servlet-name>
<url-pattern>/</url-pattern>
</servlet-mapping>
</web-app>

En este segundo intento acceder al link de la imagen (ruta/imagen.jpg) y me dice que el método no está permitido.

No se como hacer para que me funcione el servlet y a la vez se vean las imágenes. ¿A alguién se le ocurre cual puede ser el error?

Muchas gracias.
Un saludo.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder