Visual Basic.NET - Cifra con cero inicial que no se ve en datagrid...

   
Vista:

Cifra con cero inicial que no se ve en datagrid...

Publicado por il_drago (2 intervenciones) el 23/07/2009 12:05:08
Hola compañeros,

Tengo un datagrid conectado a una base de datos Acces, y no consigo que me muestre las cifras tal y como están en la base de datos. Hay muchas cifras que empiezan por el dígito "0" (05153, por ejemplo), y al pasar al datagrid, ese cero inicial me desaparece.

En la Access, los datos están declarados como "entero largo" de formato "00000".

Un saludo.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Cifra con cero inicial que no se ve en datagrid

Publicado por Damian (824 intervenciones) el 23/07/2009 23:58:08
Y porque no cambias el tipo de dato en Access a string, siempre es mejor trabajar con string a menos que tengas que hacer cuentas(sumas,restas,etc.). Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Cifra con cero inicial que no se ve en datagrid

Publicado por il_drago (2 intervenciones) el 24/07/2009 00:53:22
Gracias por contestar Damian...

El caso es que al principio, declaré los datos de la Access como string, pero me daba el mismo error, y como bien dices, si necesitaré mas adelante hacer cálculos con dichos datos...

Me da que el cambio de formato lo crea un simple valor de propiedad del datagrid, o del tablaset, pero por mas que me lo miro y remiro, no consigo dar con lo que es :S ....
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar