Visual FoxPro.NET - ERROR CON REPORT....URGENTE

   
Vista:

ERROR CON REPORT....URGENTE

Publicado por Juan Ayala (2 intervenciones) el 20/10/2008 15:09:00
Hola,
genero un cursor a partir 2 de tablas con mas de 500.000 registros, cada una aprox. , en el cursor van los datos resumidos, que van en tres paginas de un report.
El Error es el siguiente; despliega la primera hija, al querer correr y visualizar la segunda pagina del reporte, me da un aviso de que la variable "CODIGO" no encuentra, sin embargo esa variable codigo es un campo del cursor generado... me parece sumamente raro este error, siendo que me a desplegado toda la primera pagina, donde existe el campo CODIGO... No se que hacer, ya replantee mi reporte, mi form, etc. cambie de plataforma, de red... me sigue apareciendo este error que al final me da el Error Code=C000000005.... etc. etc

Si algun alma misericordiosa que sepa, puede ayudarme lo agradecere eternamente, pues ya tengo problemas con mi cliente...
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:ERROR CON REPORT....URGENTE

Publicado por Daniel GC (3 intervenciones) el 23/10/2008 16:25:57
Hola, mira en una aplicación que realice me aparecia el mismo error, al generar un cursor con una consulta y mandarla al reporte me marcaba que tal campo no existia en la tabla.

El problema es que al generar el cursor, se cambia de tabla (el porque no lo se), y no importa cuantas veces lo pongas en el área de trabajo no te lo toma en cuenta, aunque la tabla exista.

La solución que encontre, (se que no es la mejor pero me paso lo mismo que a ti, se me vino el tiempo encima) fue generar o 2 veces el codigo de la consulta o si tu consulta es muy grande hacer una consulta con un valor cualquiera de tu cursor y despues realizar tu consulta con el mismo nombre de cursor.

Seguire investigando pero espero que esto te ayude.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ERROR CON REPORT....URGENTE

Publicado por alberto (6 intervenciones) el 31/10/2008 00:54:12
YO PROBARIA CON LO SIGUIENTE:
PRIMERO EN EL REPORTE PONER PARA QUE IMPRIMA EL NOMBRE DE LA TABLA CON EL NOMBRE DEL CAMPO, EJE TEMP.CODIGO Y PROBARIA DE ASIGNARLE A UNA VARIABLE EL NOMBRE DEL CAMPO EJE CODI=TEMP.CODIGO Y DECLARARLA PUBLICA EN EL INIT DEL REPORTE, SE ME OCURRE ESO, ES CUESTION DE PROBAR,
CON RESPECTO AL FAMOSO ERROR C0000005 FIJATE COMO TRABAJAS CON LOS SELECT O USE , VERIFICA DE CERRAR BIEN TODO CDO SALE, PUDE ESTAR AHI EL ERROR.
SALUDOS Y SUERTE
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar