Algoritmia - raiz enesima con recursividad

 
Vista:
Imágen de perfil de Francisco
Val: 4
Ha disminuido su posición en 6 puestos en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

raiz enesima con recursividad

Publicado por Francisco (4 intervenciones) el 21/05/2018 18:55:35
Hola, les mando mi aporte de hacer un algoritmo para hallar la raiz enesima con recursividad.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
Programa principal
 
int n;
 
float radicando;
 
float resultado;
 
inicio
 
  escribir ("ingrese el indice");
 
  leer(n);
 
 escribir("ingrese el radicando");
 
 leer(radicando);
 
 resultado = raizenesima(n,radicando);
 
escribir("el resultado de la raiz enesima es: ", resultado);
 
fin
 
funcion raizenesima(int veces, float radic):float
 
          float aux = 1.0;
 
            int j;
          float i = 0;
 
           i = i + 0.00001;
        para(j=0 hasta j<veces hacer j++)
 
              aux = aux * i;
 
        fin para
 
         si (veces == 0) entonces
 
            return 1;
         sino
                  return raizenesima(veces,radic);
 
           fin si
 
        fin funcion

¿Qué pueden pensar que este mal en el algoritmo?, ¿funciona?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de gilman
Val: 4
Ha disminuido su posición en 3 puestos en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

raiz enesima con recursividad

Publicado por gilman (4 intervenciones) el 22/05/2018 08:46:09
No, no funcionará, solo funcionará si veces= 0, en el resto de los casos se producirá un bucle infinito, la anterior vez que posteaste te dije como corregir el error, si tenías dudas no había necesidad de abrir otro.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar