Android - Actualizacion a las nuevas normas de googlePlay

 
Vista:
Imágen de perfil de Francisco
Val: 406
Oro
Ha mantenido su posición en Android (en relación al último mes)
Gráfica de Android

Actualizacion a las nuevas normas de googlePlay

Publicado por Francisco (342 intervenciones) el 19/03/2019 21:51:16
Hola he actualizado una aplicacion y ala hora de subirla se me ha complicado mucho



no me dejaba subirla porque decia que la api minima de destino deberia ser 26 o mayor

si pongo

compileSdkVersion 26

me falla esta linea
compile 'com.android.support:appcompat-v7:25.3.1'

y si pongo

compileSdkVersion 25

el 25 se queda marcado en rojo pero la aplicacion compila bien

incluso la he podido subir a googlePlay la custion es que algo esta mal.


Lo que quiero es poner targetSdkVersion 26 o mayor

Sabe qlguien como solucionarlo

Gracias:



1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
apply plugin: 'com.android.application'
apply plugin: 'com.google.gms.google-services'
 
android {
    compileSdkVersion 25
    buildToolsVersion "25.0.3"
    defaultConfig {
        applicationId "com.pmrh.pastillero"
        minSdkVersion 15
        targetSdkVersion 26
        versionCode 58
        versionName "5.8"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    productFlavors {
    }
}
 
dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    compile 'com.android.support:appcompat-v7:25.3.1'
    compile 'com.android.support.constraint:constraint-layout:1.0.2'
    testCompile 'junit:junit:4.12'
    compile 'com.google.firebase:firebase-ads:9.0.0'
}
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 86
Bronce
Ha mantenido su posición en Android (en relación al último mes)
Gráfica de Android

Actualizacion a las nuevas normas de googlePlay

Publicado por Cesar (33 intervenciones) el 19/03/2019 22:22:24
Hola.

Tienes que actualizar el SDK de Android.

Tienes instalado el 25, pero te estan pidiendo el 26.

Ejecuta el SDK Manager, agrega el SDK de la API 26, modifica tu proyecto para apuntar a dicho SDK, y listo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Francisco
Val: 406
Oro
Ha mantenido su posición en Android (en relación al último mes)
Gráfica de Android

Actualizacion a las nuevas normas de googlePlay

Publicado por Francisco (342 intervenciones) el 20/03/2019 00:53:22
Gracias por la orintacion ya he encontrado una solucion

compile 'com.android.support:appcompat-v7:26.+'
compile 'com.android.support:design:26.+'

al estar en targetSdkVersion 26
no admitia
compile 'com.android.support:appcompat-v7:25.3.1'
por eso falllaba .

Saludos;
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar