Excel - formula

 
Vista:

formula

Publicado por ESTHER (1 intervención) el 26/07/2019 22:06:05
buenas necesito hacer una formula en excel para aplicar porcentajes variados dependiendo de las cantidades .

se trata de esto :

si compro una cantidad fija en un producto . pero el fabricante me despacha mas docenas de las que pedi , debo aplicar una penalidad que seria asi:

de 6 docena a 20 docenas de mas aplicar una penalidad de 10%
de 21 docena a 50 docenas de mas aplicar una penalidad de 35%
de 51 docenas en adelante aplicar una penalidad de 50%.

si alguien puede ayudarme les agradeceria. mi mail es esthercita1923@hotmail.com
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Hector Madriz
Val: 857
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

formula

Publicado por Hector Madriz (137 intervenciones) el 26/07/2019 23:08:24
Buen dia, prueba esto:

1
=SI(Y(ESNUMERO(A1);A1>=0);SI(Y(A1>=0;A1<=20);10;SI(Y(A1>=21;A1<=50);35;50));"ERROR")

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com
Val: 6.362
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

formula

Publicado por wordexperto.com (2193 intervenciones) el 27/07/2019 13:39:27
Hola a todos:
Tantos si anidados son difíciles de evaluar. Esto es un caso típico de buscarv verdadero.
https://www.youtube.com/channel/UCxgRcbeR2q4PpE1Pgft74Iw


Captura

Si no quieres usar rangos auxiliares, usa elegir+coincidir: =ELEGIR(COINCIDIR(E3;{0;6;20;50});0;0,1;0,35;0,5)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
Imágen de perfil de Hector Madriz
Val: 857
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

formula

Publicado por Hector Madriz (137 intervenciones) el 27/07/2019 15:27:38
Ciertamente la formula es mas difícil de entender para el usuario, sin embargo es más fácil de evaluar para la Hoja de Cálculo por consiguiente es mas eficiente.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar