Excel - Código alfanumérico (no aleatorio) consecutivo

 
Vista:

Código alfanumérico (no aleatorio) consecutivo

Publicado por Sol (1 intervención) el 14/11/2020 01:13:02
Hola,

Necesito generar un código alfanumérico consecutivo.
Este código debe estar compuesto por lo siguiente:
- Dos letras que cogería de otra celda (sus dos primeras letras concretamente)
- Número de cuatro dígitos (comenzando por el 0100)
- Dos letras que cogería de otra celda diferente de la primera (sus dos primeras letras concretamente)
De esta manera un ejemplo del código sería: PE0100DO (PE serían las dos primeras letras de otra celda y DO serían las dos primeras letras de otra celda diferente) estos datos variarían en función de la información que metamos en esas celdas.
Tengo esta formula pero no termina de funcionar correctamente:

=IZQUIERDA(B12;2)&TEXTO(FILA(B1);"0100")&IZQUIERDA(E12;2)

No consigo que la numeración sea consecutiva cada vez que introduzco nuevos valores en la base de datos.

Quizás sea más fácil utilizar una macro, pero estoy igual de perdida.

Por favor, alguien podría ayudarme con este tema?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com
Val: 6.777
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Código alfanumérico (no aleatorio) consecutivo

Publicado por wordexperto.com (2384 intervenciones) el 14/11/2020 08:04:34
Ya te he contestado en el otro foro. Aquí sí puedes subir directamente el archivo, aunque reitero el ofrecimiento para que lo mandes a mi correo.
https://www.youtube.com/channel/UCxgRcbeR2q4PpE1Pgft74Iw
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Andres Leonardo
Val: 3.733
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Código alfanumérico (no aleatorio) consecutivo

Publicado por Andres Leonardo (1534 intervenciones) el 16/11/2020 15:33:08
Como bien dice PEPE necesitamos un ejemplo ... yo según lo que entiendo utilizaría , contar.si.conjunto validando que se cumplan los dos códigos, y un generar código. te dejo la captura en dos partes para que entiendas lo que se hizo, esto puede sin problema ser únicamente una sola formula pero sin ejemplo la verdad no lo se, yo puse los valores por que no se de donde los extraes pero para el ejemplo es valido

Saludos a todos espero estén bien y que sea lo que necesitas.

Andres

Formulas
1
2
3
4
5
C:
=SI(O(A2<>"";B2<>"");CONTAR.SI.CONJUNTO($A$2:A2;A2;$B$2:B2;B2);0)
 
D:
=SI(C2>0;CONCATENAR(A2;TEXTO(C2;"0000");B2);"")


COdigoUnico
COdigoUnico2
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar