Java - Ayuda con Test Parametrico en java netbeans

 
Vista:
Imágen de perfil de Miguel
Val: 5
Ha aumentado su posición en 9 puestos en Java (en relación al último mes)
Gráfica de Java

Ayuda con Test Parametrico en java netbeans

Publicado por Miguel (3 intervenciones) el 29/06/2018 02:11:52
Hola buen dia a todos estoy iniciando con programacion y lo que me complica mas son los la verificacion de resultados con un testing parametrico con la biblioteca TestNG no me manejo mucho en los test si alguien me podria ayudar o guiar se lo agradeceria mucho gracias ; )


en pseudocodigo lo tengo asi

Algoritmo Monedas
Escribir "Precio del Pdcto A $270";
Escribir "Precio del Pdcto B $340";
Escribir "Precio del Pdcto C $390";
Escribir Sin Saltar "Ingresa el código A, B o C";
leer codigoProducto;
si(codigoProducto <> "A" && codigoProducto<>"B" && codigoProducto<>"C")entonces
Escribir "Error de Ingreso";
Sino
Si codigoProducto="A" Entonces
precio=270;
SiNo
Si codigoProducto="B" Entonces
precio=340;
SiNo
precio=390;
FinSi
FinSi
Escribir "Ingresa las monedas (10) - (50) - (100)";
montoMonedas=0;
Mientras montoMonedas<precio Hacer
Escribir Sin Saltar "Ingresa una moneda";
leer moneda;
montoMonedas=montoMonedas+moneda;
FinMientras
Escribir "El vuelto es:";

montoMonedas=montoMonedas-precio;

vueltoMonedaCincuenta=trunc(montoMonedas/50);
vueltoMonedaDiez=trunc((montoMonedas mod 50)/10);


para i=1 hasta vueltoMonedaCincuenta con paso 1 hacer
escribir 50;
FinPara

para i=1 hasta vueltoMonedaDiez con paso 1 hacer
escribir 10;
FinPara

FinSi
FinAlgoritmo


------------------------------------------------------------------------JAVA--------------------------------------------------------------------

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
Scanner sca = new Scanner(System.in);
 
    String codigoproducto;
    double i;
    double moneda;
    double montomonedas;
    double precio;
    int vueltomonedacincuenta;
    int vueltomonedadiez;
    System.out.println("Precio del Pdcto A $270");
    System.out.println("Precio del Pdcto B $340");
    System.out.println("Precio del Pdcto C $390");
    System.out.print("Ingresa el código A, B o C");
    codigoproducto = sca.next();
    if((("A".equals(codigoproducto)) && ("B".equals(codigoproducto))) && ("C".equals(codigoproducto))){
        System.out.println("Error de Ingreso");
    } else {
        if (codigoproducto.equals("A")) {
            precio = 270;
        } else {
            if (codigoproducto.equals("B")) {
                precio = 340;
            } else {
                precio = 390;
            }
        }
        System.out.println("Ingresa las monedas (10) - (50) - (100)");
        montomonedas = 0;
        while (montomonedas<precio) {
            System.out.print("Ingresa una moneda");
            moneda = Double.parseDouble(sca.next(codigoproducto));
            montomonedas = montomonedas+moneda;
        }
        System.out.println("El vuelto es:");
        montomonedas = montomonedas-precio;
        vueltomonedacincuenta  = (int) Math.floor(montomonedas/50);
        vueltomonedadiez = (int) Math.floor((montomonedas%50)/10);
        for (i=1;i<=vueltomonedacincuenta;i++) {
            System.out.println(50);
        }
        for (i=1;i<=vueltomonedadiez;i++) {
            System.out.println(10);
        }
    }
}
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder