Java - Certifica SAT

 
Vista:

Certifica SAT

Publicado por Azalia (2 intervenciones) el 14/05/2024 07:05:43
Buen dia, espero alguien de aqui me pueda AYUDAR a resolver esta situacion. Descargue java oracle 8 en maquina virtual de linux debian. Mi procesador es de Chrome.

El asunto es que descargue la aplicacion de certifica de SAT para un certificado y si me abre la apliacion relativamente normal. Pero cuando llego al paso de generar lclaves me sale este error.

java -jar Certifica.jar
Exception in thread "AWT-EventQueue-0" java.lang.UnsupportedOperationException: TRANSLUCENT translucency is not supported.
at java.awt.Window.setOpacity(Window.java:3625)
at java.awt.Dialog.setOpacity(Dialog.java:1333)
at java.awt.Window$1.setOpacity(Window.java:4035)
at com.sun.awt.AWTUtilities.setWindowOpacity(AWTUtilities.java:174)
at mx.sat.gob.b.f.a(PGeneracionLlaves.java:3099)
at mx.sat.gob.b.f$2.ancestorMoved(PGeneracionLlaves.java:212)
at java.awt.Component.processHierarchyBoundsEvent(Component.java:6736)
at java.awt.Component.processEvent(Component.java:6323)
at java.awt.Container.processEvent(Container.java:2236)
at java.awt.Component.dispatchEventImpl(Component.java:4889)
at java.awt.Container.dispatchEventImpl(Container.java:2294)
at java.awt.Component.dispatchEvent(Component.java:4711)
at java.awt.Component.createHierarchyEvents(Component.java:5565)
at java.awt.Container.createHierarchyEvents(Container.java:1445)
at java.awt.Container.createHierarchyEvents(Container.java:1441)
at java.awt.Container.createHierarchyEvents(Container.java:1441)
at java.awt.Container.createHierarchyEvents(Container.java:1441)
at java.awt.Container.createChildHierarchyEvents(Container.java:1459)
at java.awt.Container.dispatchEventImpl(Container.java:2303)
at java.awt.Window.dispatchEventImpl(Window.java:2746)
at java.awt.Component.dispatchEvent(Component.java:4711)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
at java.awt.EventQueue$4.run(EventQueue.java:731)
at java.awt.EventQueue$4.run(EventQueue.java:729)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Ojala alguien de aqui pueda ayudarme, ya busque en todos lados..
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Kabuto
Val: 3.428
Oro
Ha mantenido su posición en Java (en relación al último mes)
Gráfica de Java

Certifica SAT

Publicado por Kabuto (1383 intervenciones) el 14/05/2024 10:46:25
Hola.
Parece que el programa está intentando ejecutar una funcionalidad gráfica (translucencia) que no estaría soportada por la interfaz gráfica del sistema operativo.
Quizás sea un problema al correrlo bajo Linux.

Yo he hecho una prueba bajo Windows 10, inventándome un RFC y un CURP (soy de España) y he podido llegar hasta el último paso (sin completarlo ya que he usado datos ficticios) y no me ha surgido ningún error.

Así que inténtalo bajo Windows o incluso con una distribución Linux distinta a la que estés usando ahora.

He intentado buscar sobre la compatibilidad del programa Certifica con distintos sistemas operativos, pero no he encontrado nada.

Sí he encontrado un canal de Youtube llamado "Ayuda al Contribuyente" a quién quizás puedas consultarle mediante un comentario en sus vídeos:


Suerte y un saludo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Certifica SAT

Publicado por Azalia (2 intervenciones) el 14/05/2024 19:18:15
Hola muchas gracias por el dato. Intentare hacerlo mediante windows. Vere que tal me va.

Saludos!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar