Linux - Error login Ubuntu 16.04 en Active Directoy

   
Vista:

Error login Ubuntu 16.04 en Active Directoy

Publicado por SrBlackBit (1 intervención) el 09/11/2017 13:08:24
Hola, quería saber si me podrían ayudar con un problema que tengo hace tiempo en la empresa donde trabajo.
Resulta que tenemos una infraestructura mixta (Equipos Windows y Equipos con linux). Que básicamente esta formada de la siguiente manera.

- 1 equipo que actúa como servidor de dominio. El cual contiene Windows Server 2003 con los servicios de active directory (AD) y samba corriendo (SMB).
- Varios equipos con Windows (7, 10, XP)
- Varios equipos con Ubuntu 16.04

Resulta que los equipos con Ubuntu estan conectados al dominio de distintas formas. En algunos se utilice herramienta que fui encontrando en la web, en otros realice la configuración manualmente de los servicios kerberos, ldap, smb, etc.

El inconveniente que tengo esta a la hora de iniciar sesión.
Cuando inicio la PC y llego al login, pasa lo siguiente. Si conectó bien al domino, me aparecen los usuarios que se registraron previamente a la maquina (Ej: ADPepe,ADJuan) sino, me aparecen directamente los usuarios locales y para registrar uno nuevo. (Ej: LocalMarcos, login). Hay casos en que reinicio la maquina y no se porque el AD me bloquea el equipo. Pero habilitando el equipo en el AD y volviendo a reiniciar, aparecen los usuarios en el login.
Pero el problema mas importante me sucede a la hora de loguearse en el equipo. Este logueo se puede realizar utilizando el entorno Cinnamon o Gnome. Si selecciono el Cinnamon en el primer logueo el SO me arroja un error que dice "Fallo al iniciar sesión".

La solución que le encontré a esto fue, una vez que me arroja ese error, reinicio la PC, en el login selecciono el entorno de GNOME e ingreso las credenciales del usuario. Una vez que el usuario ingresa, cierro sesión, selecciono el entorno Cinammon y recién ahí el usuario se puede loguear.

Esto me vuelve a sucecer a veces cuando cierro la sesión del usuario y quiero ingresar con uno nuevo.
Estoy frustrado porque ya realizamos muchísimas pruebas y diferentes modos de conectar el ubuntu 16.04 al dominio y sin embargo el problema sigue.

Si alguien tuvo este problema o creo que me puede ayudar, encantado.
Si necesitan que proporcione mas información, estoy a su disposicion.

Saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder