Linux - stderr: "Could not open required defaults file: /home/xve/.local/share/akonadi/mysql.conf\nFatal

   
Vista:
Imágen de perfil de xve

stderr: "Could not open required defaults file: /home/xve/.local/share/akonadi/mysql.conf\nFatal

Publicado por xve (758 intervenciones) el 20/12/2017 13:16:20
Hace unos dias actualice mi versión de Debian testing, y dejo de funcionarme akonadi, con lo que no puedo utilizas las aplicaciones de kmail, kontact, ...

Al intentar ejecutarlo, me da el error:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
akonadictl start
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
akonadiprivate_log: search paths:("/home/xve/perl5/bin", "/usr/local/bin", "/usr/bin", "/bin", "/usr/local/games", "/usr/games", "/usr/local/java/jdk1.8.0_91/bin", "/usr/local/java/jdk1.8.0_91/jre/bin", "/snap/bin", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin", "/opt/mysql/sbin")
Database process exited unexpectedly during initial connection!
executable: "/usr/sbin/mysqld"
arguments: ("--defaults-file=/home/xve/.local/share/akonadi/mysql.conf", "--datadir=/home/xve/.local/share/akonadi/db_data/", "--socket=/tmp/akonadi-xve.tFxPNs/mysql.socket")
stdout: ""
stderr: "Could not open required defaults file: /home/xve/.local/share/akonadi/mysql.conf\nFatal error in defaults handling. Program aborted\n"
exit code: 1
process error: "Unknown error"
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/tmp/akonadi-xve.tFxPNs/mysql.socket' (2 "No such file or directory")'
Check that mysqld is running and that the socket: '/tmp/akonadi-xve.tFxPNs/mysql.socket' exists!
Failed to remove Unix socket
Failed to remove runtime connection config file
Application 'akonadiserver' exited normally...


Después de leer por internet, he copiado el archivo /home/xve/.local/share/akonadi/mysql.conf y carpeta /home/xve/.local/share/akonadi/db_data/ a la carpeta /tmp/ del sistema:
1
2
cp /home/xve/.local/share/akonadi/mysql.conf /tmp/
cp -r /home/xve/.local/share/akonadi/db_data/ /tmp/

y he iniciado de forma manual akonadi con:
1
/usr/sbin/mysqld --defaults-file=/tmp/mysql.conf --datadir=/tmp/db_data/ --socket=/tmp/akonadi-xve.tFxPNs/mysql.socket

Se ha iniciado correctamente, y puedo acceder a mis aplicaciones de kmail, kontact, ...


Creo que es un bug en su ultima versión... espero que lo solucionen pronto!!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Revisar política de publicidad