Linux - Problemas al montar carpeta con /etc/fstab

 
Vista:
sin imagen de perfil
Val: 1
Ha disminuido su posición en 12 puestos en Linux (en relación al último mes)
Gráfica de Linux

Problemas al montar carpeta con /etc/fstab

Publicado por Daniel (1 intervención) el 06/09/2018 11:35:57
Hola a todos.
Os planteo un problema que tengo en la empresa donde trabajo, dado que no acabo de dar con la tecla y llevo ya varios días liado con el tema.
Tenemos un NAS donde hay carpetas con información compartida por los trabajadores. Asimismo, tengo dos equipos con Linux (KUbuntu 18.04) donde quiero montar
las carpetas referidas, los cuales son utilizados por varios usuarios.

Para hacer esto, he utilizado el fichero /etc/fstab, cuyo contenido es el siguiente:

1
2
3
4
5
6
7
8
9
10
11
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=5e4326e0-9c4a-4201-b880-15406d82de1f /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda3 during installation
UUID=412aa1ca-df24-487b-908a-200ba9472814 /home           ext4    defaults        0       2
# swap was on /dev/sda1 during installation
UUID=208e9263-5493-4a8c-8b7f-f92ccaf64bc5 none            swap    sw              0       0
 
#Acceso al NAS
//200.2.2.100/Operativos /home/pedro/Operativos cifs user=pedro,pass=pass_pedro,dom=DOMINIO_EMPRESA,uid=pedro,gid=pedro,auto 0 0
......

Este mecanismo crea para el usuario "pedro", en su directorio home, una carpeta llamada "Operativos" donde está montada la carpeta del NAS referida.
Hay que decir que los usuarios tienen usuario y contraseña coincidentes con las definidas para el NAS, para evitar problemas.
Pues bien, de los dos equipos Linux que tengo con idéntica distribución, EN UNO FUNCIONA CORRECTAMENTE Y EN EL OTRO NO!!
Cuando se reinician los equipos, en uno de ellos se puede acceder a la carpeta montada (todo correcto), mientras que en el otro está vacía, observándose a través del administrador de archivos el mensaje siguiente:

"Ocurrió un error al acceder a «Operativos en 200.2.2.100», el sistema respondió: mount: /home/pedro/Operativos: operación autorizada solo a root."

Tras obtener el error, intenté montar la unidad manualmente a través del siguiente comando:

"sudo mount -a"

Y obtuve el siguiente mensaje de error:

"mount: /home/pedro/Operativos: opción incorrecta; para varios sistemas de ficheros (v.g. nfs, cifs) podría ser necesario un programa auxiliar /sbin/mount.<tipo>."

Se ha instalado en ambos equipos Samba y NFS, estando el sistema debidamente actualizado.
Pensé que podría tratarse de los privilegios de la carpeta donde realizo el montaje, así que le puse todos los permisos posibles (chmod 777 /home/pedro/Operativos), y al ver que seguía sin funcionar, cmabié el propietario de la carpeta al root, pero tampoco funcionó.
Probé por último a borrar la carpeta donde realizaba el montaje, para que se crease automáticamente al iniciar el sistema, y sí, se creaba correctamente, pero persistía el error del montaje.

Lo que me tiene despistado es por qué funciona lo mismo en uno si, y en el otro no. ¿Puede que me falte algo por instalar?.
Por favor, si alguien me puede aportar algo de ayuda, sería muy bien recibida.

Muchas gracias, y perdón por el tocho de información.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problemas al montar carpeta con /etc/fstab

Publicado por Tom (455 intervenciones) el 06/09/2018 15:17:44
Solo por tantear ... ¿ el usuario pedro en las dos máquinas Linux tiene el mismo uid y gid ?
¿ Has probado la listar (en ambas máquinas) el contenido de /sbin ?

# ls -la /sbin/mount*
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve
Val: 231
Oro
Ha mantenido su posición en Linux (en relación al último mes)
Gráfica de Linux

Problemas al montar carpeta con /etc/fstab

Publicado por xve (825 intervenciones) el 06/09/2018 17:22:18
Hola Daniel, has probado a instalarlo manualmente? algo así:
1
sudo mount -t cifs //200.2.2.100/Operativos /home/pedro/Operativos -o user=pedro,pass=pass_pedro
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar