Linux - [solucionado] OpenSSL - Permitir utilizar cualquier versión de TLS

 
Vista:
Imágen de perfil de xve
Val: 155
Oro
Ha mantenido su posición en Linux (en relación al último mes)
Gráfica de Linux

[solucionado] OpenSSL - Permitir utilizar cualquier versión de TLS

Publicado por xve (825 intervenciones) el 07/02/2019 10:52:07
En la actualización a la versión 1.1 de openssl en GNU/Debian testing, no permite utilizar ninguna versión inferior a TLS1.2 por recomendaciones de seguridad.

Al actualizar la versión de openssl, nos dejo de funcionar kmail con algunos servidores de correo...

Para solucionar este problema, hay que indicar a openssl que permita cualquier versión modificando el archivo /etc/ssl/openssl.cnf

Hay que modificar las lineas:
1
2
MinProtocol = TLSv1.2
CipherString = DEFAULT@SECLEVEL=2

Por:
1
2
MinProtocol = None
CipherString = DEFAULT
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
1
Responder