Linux - Problemas con Usuarios AD en CentIOS /

 
Vista:
sin imagen de perfil
Val: 5
Ha aumentado su posición en 4 puestos en Linux (en relación al último mes)
Gráfica de Linux

Problemas con Usuarios AD en CentIOS /

Publicado por Ezequiel (2 intervenciones) el 22/02/2019 15:32:45
Buenas tardes
estaria necesitando ayuda ya que estoy teniendo el siguiente problema
tengo un servidor hp proliant 8va generacion con un CentOS 7 instalado, sobre este sistema corro dos virtualizaciones con quemu/kvm de Windows 2008 R2 (un dominio y un terminal server), y a su vez un servidor samba.
El centos esta integrado al dominio Windows a travez de Winbind y tanto el Linux como el samba utilizan los usuarios del dominio para manejar los permisos.
el problema viene que el CentOS me reconoce todos los usuarios del dominio exepto dos, esos usuarios solo me muestra el UID, pero el grupo de esos usuarios los reconoce sin problema.
si dese bash consulto la lista de usuarios del dominio esos dos usuarios con problemas me aparecen bien. y cualquier tipo de consulta funciona. el unico problema lo tengo en el momento que el CentOS asigna los usuarios a las carpetas.

adjunto salidas de comandos

Permisos de carpetas

[root@xxxxxxx ~]# ls -lha /home
total 152K
drwxr-xr-x. 28 root root 4,0K feb 20 14:22 .
dr-xr-xr-x. 21 root root 4,0K feb 18 12:32 ..
drwx------ 3 auxiliar auxiliar 4,0K ene 28 10:13 auxiliar
drwx------ 4 backup backup 4,0K jun 1 2018 backup
drwxrwx--- 21 cpocai cpocai 4,0K feb 21 11:26 cpocai
drwxrwx--- 3 despacho despacho 4,0K may 9 2018 despacho
drwxrwx--- 7 10001109 dsilva 4,0K feb 4 17:57 dsilva
drwxrwx--- 2 flanari flanari 4,0K jul 17 2018 flanari
drwxrwx--- 3 10001121 mbergesio 4,0K feb 15 15:11 mbergesio
drwxrwx--- 3 mcabana mcabana 4,0K may 2 2018 mcabana

leer id

[root@xxxxxxx ~]# id -u dsilva
id: dsilva: no existe ese usuario

[root@xxxxxxx ~]# id -u cpocai
10001107

consultar al dominio
[root@xxxxxxx ~]# wbinfo --domain-users
administrador
invitado
cpocai
despacho
dsilva
flanari
mbergesio
backup
auxiliar


como veran en la consulta aparecen, en la lista de permisos aparecen solo en grupo pero no en usuario.
este error fue de un dia para el otro. primero paso con uno y despues con el otro.

si es necesario subo configuraciones de archivos smb.conf krb5.conf y lo que necestien.
otra cosa. este servidor esta configurado igual que otros dos que tengo de caracteristicas similares y en los mismos no tengo problemas.

desde ya muchas gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve
Val: 150
Oro
Ha mantenido su posición en Linux (en relación al último mes)
Gráfica de Linux

Problemas con Usuarios AD en CentIOS /

Publicado por xve (825 intervenciones) el 23/02/2019 08:23:21
Hola Ezequiel, has revisado el archivo /etc/passwd que esos usuarios esten bien definidos??

Me da la sensación que no estan!!!

Si te fijas, en el listado del /home/ esos usuario no tienen nombre, solo tienen un id... es como se ubieran eliminado los usuarios del /etc/passwd
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 5
Ha aumentado su posición en 4 puestos en Linux (en relación al último mes)
Gráfica de Linux

Problemas con Usuarios AD en CentIOS /

Publicado por Ezequiel (2 intervenciones) el 23/02/2019 13:30:45
Los usuarios son leídos desde el dominio de Windows por ese motivo no aparece ninguno en el archivo passwd
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar