Pseudocódigo/Diagramas de Flujo - me podria ayudar a terminar este ejercicio de psint

 
Vista:
sin imagen de perfil
Val: 3
Ha aumentado su posición en 3 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

me podria ayudar a terminar este ejercicio de psint

Publicado por diego (2 intervenciones) el 26/08/2018 16:15:13
me podría ayudar a terminarlo el problema es que me da un error 274 que dice que la (dimensión resultado tiene k ser mayor a 0 y pues no puedo pasar de hay de ese error pues es la suma de dos matrices de 3x3 si tiene alguna otra forma de hacerlo no importa le acepto el código con mucho gusto gracias de antemanos

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
Algoritmo SUMAR_MATRICES
	// Nuestra Primera Matriz
	Escribir 'Ingrese el numero de Filas Para la Primera Matriz '
	Leer Filas
	Escribir 'Ingrese el numero de Columnas para la Primera Matriz '
	Leer Columnas
	// Nuestras Segunda Matriz
	Escribir 'Ingrese el numero de Filas Para la Segunda Matriz '
	Leer Filas1
	Escribir 'Ingrese el numero de Columnas para la Segunda Matriz '
	Leer Columnas1
	// Planteamos una Dimension para nuestra Primera Matriz
	Dimension Matriz[Filas,Columnas]
	// usamos el comando "Para" para introducir los datos en nuestra primera matriz
	Para i<-1 Hasta Filas Hacer // este PARA es pa las filas
		Para j<-1 Hasta Columnas Hacer // este PARA es para las columnas
			Escribir 'INGRESE LAS POSICIONES 1 '
			Leer Matriz[i,j]
		FinPara
	FinPara
	// Plateamos una Dimension para nuestra Segunda Matriz
	Dimension Matriz2[Filas1,Columnas1]
	// Decimos que la suma es igual a CERO
	suma <- 0
	// Dimensionamos el resultado para utilizarlo en el mismo comando PARA
	Dimension resultado[i,j]
	//Usamos el comando PARA para introducir los datos de nuestra segunda matriz
	Para i<-1 Hasta Filas1 Con Paso 1 Hacer//este Para es pa las filas
		Para j<-1 hasta Columna1 Con Paso 1 hacer//este para es pa las columnas
			Imprimir "INGRESE LAS POSICIONES 2 "
			Leer Matriz2[i,j]
			//como la suma la igualamos a CERO ahora la igualamos a la suma de nuestra primera y segunda matriz
			suma<-Matriz[i,j]+Matriz2[i,j]
			//el resultado lo igualamos a la suma
			resultado[i,j]=suma
		FinPara
	FinPara
	//se usa el ciclo PARA pa poderlo imprimir el resultado
	Para i<-1 Hasta Filas Con Paso 1 Hacer
		Imprimir "posisiones ",i
		Para j<-1 Hasta Filas1 Con Paso 1 Hacer
			Imprimir resultado[i,j]
		FinPara
	FinPara
FinAlgoritmo
matriz-diagrama
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

me podria ayudar a terminar este ejercicio de psint

Publicado por codeBY (3 intervenciones) el 26/08/2018 21:47:03
ola que tal alejandro somos codeBY una comunidad dedicada al apoyo de estudiantes de programación como tu puedes enviarnos un correo codebynar@gmail.com para darnos mas especificaciones de tu problema en un instantes nos compremetemos a publicar en youtube la solucion o en el foro saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 3
Ha aumentado su posición en 3 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

me podria ayudar a terminar este ejercicio de psint

Publicado por diego (2 intervenciones) el 27/08/2018 00:31:16
acabo de enviarle toda la informacion a su corrreo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 16
Ha aumentado 1 puesto en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

me podria ayudar a terminar este ejercicio de psint

Publicado por dario (10 intervenciones) el 07/09/2018 16:05:00
Tu mismo codigo arreglado.
Salu2.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
Algoritmo sin_titulo
	// Nuestra Primera Matriz
	Escribir 'Ingrese el numero de Filas Para la Primera Matriz '
	Leer Filas
	Escribir 'Ingrese el numero de Columnas para la Primera Matriz '
	Leer Columnas
	// Nuestras Segunda Matriz
	Escribir 'Ingrese el numero de Filas Para la Segunda Matriz '
	Leer Filas1
	Escribir 'Ingrese el numero de Columnas para la Segunda Matriz '
	Leer Columnas1
	// Planteamos una Dimension para nuestra Primera Matriz
	Dimension Matriz[Filas,Columnas]
	// usamos el comando "Para" para introducir los datos en nuestra primera matriz
	Para i<-1 Hasta Filas Hacer // este PARA es pa las filas
		Escribir 'MATRIZ Nro 1'
		Para j<-1 Hasta Columnas Hacer // este PARA es para las columnas
			Escribir 'INGRESE LA POSICION ',i,',',j,':'
			Leer Matriz[i,j]
		FinPara
	FinPara
	// Plateamos una Dimension para nuestra Segunda Matriz
	Dimension Matriz2[Filas1,Columnas1]
	// Decimos que la suma es igual a CERO
	suma <- 0
	// Dimensionamos el resultado para utilizarlo en el mismo comando PARA
	Dimension resultado[Filas,Columnas]
	//Usamos el comando PARA para introducir los datos de nuestra segunda matriz
	Para i<-1 Hasta Filas1 Hacer//este Para es pa las filas
		Escribir 'MATRIZ Nro 2'
		Para j<-1 hasta Columnas1 Hacer//este para es pa las columnas
			Escribir  'INGRESE LA POSICION ',i,',',j,':'
			Leer Matriz2[i,j]
		FinPara
	FinPara
	//suma de las matrices
	Para i<-1 Hasta Filas Hacer
		Para j<-1 Hasta Columnas Hacer
			resultado[i,j] = Matriz[i,j] + Matriz2[i,j]
		Fin Para
	Fin Para
	//se usa el ciclo PARA pa poderlo imprimir el resultado
	Escribir ''
	Escribir 'SUMA DE LAS MATRICES'
	Para i<-1 Hasta Filas Con Paso 1 Hacer
		//Imprimir "posisiones ",i
		Para j<-1 Hasta Filas1 Con Paso 1 Hacer
			Escribir resultado[i,j],' ' Sin Saltar
		FinPara
		Escribir ''
	FinPara
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar