Python - traducir del psint a phyton

   
Vista:

traducir del psint a phyton

Publicado por paul (2 intervenciones) el 25/05/2017 01:34:43
Algun alma caritativa, que me lo traduzca a phyton este simple programita. Gracias
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
Algoritmo sin_titulo
	n<- 5
	i<-1
 
	Mientras i<=9 Hacer
 
		j<-1
		Mientras j<=5-n Hacer
			Escribir sin saltar " "
			j<-j+1
		Fin Mientras
 
		k<-1
		Mientras k<= n Hacer
			Escribir sin saltar  "*"
			k<-k+1
		Fin Mientras
 
		Si i<5 Entonces
			n<- n -1
		Sino
			n<- n +1
		Fin Si
 
		Escribir ""
		i<-i+1
	Fin Mientras
FinAlgoritmo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

traducir del psint a phyton

Publicado por dario (26 intervenciones) el 25/05/2017 11:49:54
Aqui lo tienes, esta en Python3

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
n = 5
i = 1
 
while i <= 9:
  j = 1
  while j <= 5-n:
    print(' ',end='')
    j += 1
 
  k = 1
 
  while k <= n:
    print('*',end='')
    k += 1
 
  if i < 5:
    n -= 1
  else:
    n += 1
 
  print('')
  i+= 1
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Revisar política de publicidad