Android - Ayuda: mi app no es compatible con algunas versiones de android?

   
Vista:
Imágen de perfil de Edgar Rafael

Ayuda: mi app no es compatible con algunas versiones de android?

Publicado por Edgar Rafael (7 intervenciones) el 23/10/2015 01:11:31
Hola..yo utilizo el android studio..cree una aplicacion, cuando pase a mi celular que tiene android 4.4.2 si me funciona, tambien probe con otros dispositivos con la misma version, pero ahora tengo un galaxy s5 con android 5.0.1 y me dice que se ha detenido, tambien probe con otros con celulares con android distintos pero solo funciona con 4.4.2...como hago para que funcione con todas las versiones o por lo menos las mas nuevas?? ayuda porfabor
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Ayuda: mi app no es compatible con algunas versiones de android?

Publicado por juanki (172 intervenciones) el 23/10/2015 22:05:41
Hola

Te quoteo:

"ahora tengo un galaxy s5 con android 5.0.1 y me dice que se ha detenido"

Lo primero que tienes que averiguar es por qué se ha detenido, si pruebas la aplicación con el móvil conectado podrás ver en el logcat el error exacto que ocurrió.

Cuando creas un proyecto una de las cosas que te pregunta AndroidStudio es la versión mínima en la que va a funcionar, pero eso es para las versiones inferiores, si has creado el proyecto con la 4.4.2, debería funcionarte en la 5.0.1, así que revisa el log a ver cual es el error que te da.

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar