Android - Cambiar SDK 23

   
Vista:

Cambiar SDK 23

Publicado por Hernan (1 intervención) el 04/04/2016 19:03:50
Hola, estoy realizando un proyecto en Android Studio (App que se conecta mysql mediante un webservice php) basándome en tutoriales, pero cuando utilizo HttpGet, HttpClient & DefaultHttpClient me muestra org.apache.http.client.HttpClient' is deprecated, estuve investigando y según algunos foros es porque el SDK23 ya no utiliza esto.

Intente agregando en el Grandle:
useLibrary 'org.apache.http.legacy'

compile 'org.apache.httpcomponents:httpcore:4.4.1'
compile 'org.apache.httpcomponents:httpclient:4.5'

pero fue inútil, lo que hace es tacharme los HttpGet.

Alguien sabe alguna alternativa a esto. O como cambiar mi SDK23 a versiones anteriores.

Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Cambiar SDK 23

Publicado por Yamil Bracho (68 intervenciones) el 05/04/2016 05:45:05
Usa Url y HttpURLConnection
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Cambiar SDK 23

Publicado por Ricardo (7 intervenciones) el 08/08/2016 19:49:16
Puedes ir a tu SDK Manager e instalar un versión anterior a la 23, como la 21, yo utilice HttpGet y no tuve ningún incoveniente.
Y al empezar a crear tu aplicación eliges el SDK inferior a 23 que instalaste, y podrías comenzar a probar.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar