FoxPro/Visual FoxPro - Conectar a base de datos en samba

   
Vista:

Conectar a base de datos en samba

Publicado por Franco (1 intervención) el 06/12/2008 00:31:22
Tengo un servidor Linux con samba yo trabajo bajo Linux, pero trabajo con Visual FoxPro, con wine me funciona bárbaro, el único problema que tengo es al momento de querer conectarme a una tabla que tengo en el samba smb://servidor/bases/tablas.dbf

Coloco
USE \ servidorases ablas
Si lo ejecuto desde windows funciona bien, si lo ejecuto desde wine (bajo linux) me dice esto
El Archivo 'c:servidorases ablas ' no existe.

Pruebas que hice:
Si pongo
USE smb://servidor/bases/tabla
Me tira: El Archivo 'c:smb:servidorases ablas ' no existe.

USE “//servidor/bases/tabla“
Me tira: El Archivo '\servidorases ablas ' no existe.

No logro que me salgan las barras / tal vez asi se conecte.
Alguien tiene alguna experiencia en esto?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Conectar a base de datos en samba

Publicado por Jose (1 intervención) el 08/12/2008 16:28:45
Yo tengo el mismo problema, si tenes la respuesta avisame por favor!!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Conectar a base de datos en samba

Publicado por Bruno (1 intervención) el 20/03/2009 13:52:34
Lo que hay que hacer es montar primero la unidad con cifs o nfs, y luego montarla en una unidad de wine

mount -t smbfs -o username=usuario,password=contraseña,uid=1000,umask=000 //ip_del_server/recurso_compartido /carpeta_de_montado/nueva_carpeta_de_montado

y luego, con winecfg montar la unidad que deseemos apuntando a /carpeta_de_montado/nueva_carpeta_de_montado

A mi me funciono, excepto con las tablas que tienen campos memo, cuando se accede a esos campos y se modifica algun valor o se agrega informacion a ese campo, da error.

Cualquier duda, contactame.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Conectar a base de datos en samba

Publicado por Carlos (1 intervención) el 17/06/2009 23:34:53
Creo tener el mismo problema, todo bien incluso el sistema no arroja error, el tema es que hacen un lío los índices. Me voy a fijar si es porque se modifican los campos memo.
Desde ya muchas gracias si alguien solucionó y quiere comentarlo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar