Java - Ayuda a pasar un programa de pseint a netbeans

   
Vista:

Ayuda a pasar un programa de pseint a netbeans

Publicado por Gonzalo gaeteramirez.gi@icloud.com (2 intervenciones) el 28/06/2016 21:16:53
Hola muy bnas tardes me estoy iniciando en programacion y estoy un poco complicado con pasar un programa de pseint a netbeans si alguien me podria ayudar seria genial gracias ; ) .

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
Algoritmo sin_titulo
	Dimension A[8,8]
	P="1"
	u=1
	para F=1 hasta 8
		para C=1 hasta 8
			si longitud(P)=1 entonces
				P="0"+P
				A[F,C]=P
			Sino
				A[F,C]=P
 
			FinSi
			si A[F,C]=A[1,3] Entonces
				P = "**"
				A[F,C]=P
			FinSi
			si A[F,C]=A[2,4] Entonces
				P= "**"
				A[F,C]=P
			FinSi
			si A[F,C]=A[3,5] Entonces
				P= "**"
				A[F,C]=P
			FinSi
			si A[F,C]=A[4,6] Entonces
				P= "**"
				A[F,C]=P
			FinSi
			si	A[F,C]=A[5,7] Entonces
				P= "**"
				A[F,C]=P
			FinSi
			si	A[F,C]=A[6,8] Entonces
				P= "**"
				A[F,C]=P
			FinSi
			u=u+1
			P=ConvertirATexto(u)
		FinPara
	FinPara
	para F=1 hasta 8
		para C=1 hasta 8
			Mostrar sin saltar " ",A[F,C]
 
		FinPara
		Mostrar " "
	FinPara
FinAlgoritmo


consiste en que mover el Alfil de la casilla 03 a la 48 eso si alguien de buena voluntad me ayuda seria bkn gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Ayuda a pasar un programa de pseint a netbeans

Publicado por Kendall tamesfern@gmail.com (2 intervenciones) el 09/07/2016 17:04:00
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
import javax.swing.JOptionPane;
 
 
/**
 *
 * @author Kendall_Tames
 */
public class NewMain {
 
    public static void main(String[] args) {
        String A[][]=new String[8][8];
        Integer u=1;
        String p="1";
        for (int f=0; f<8; f++){
            for (int c=0; c<8; c++){
                if (p.length()==1){
                    p="0"+p;
                    A[f][c]=p;
                }else{
                   A[f][c]=p;
                }
                if (A[f][c].equals(A[0][2])){
                    p= "**";
                    A[f][c]=p;
                }
                if (A[f][c].equals(A[1][3])){
                    p= "**";
                    A[f][c]=p;
                }
                if (A[f][c].equals(A[2][4])){
                    p= "**";
                    A[f][c]=p;
                }
                if (A[f][c].equals(A[3][5])){
                    p= "**";
                    A[f][c]=p;
                }
                if (A[f][c].equals(A[4][6])){
                    p= "**";
                    A[f][c]=p;
                }
                if (A[f][c].equals(A[5][7])){
                    p= "**";
                    A[f][c]=p;
                }
                        u=u+1;
                        p=Integer.toString(u);
        }
    }
    String mensaje="";
 
    for (int f=0;f<8;f++){
        for(int c=0;c<8;c++){
            mensaje=mensaje+" "+A[f][c];
        }
        mensaje=mensaje+"\n ";
    }
    JOptionPane.showMessageDialog(null, mensaje);
}
 
}

Espero te sirva.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ayuda a pasar un programa de pseint a netbeans

Publicado por Gonzalo (2 intervenciones) el 10/07/2016 01:50:23
Gracias de ante mano pero ya lo resolvi jejeje de todas formas thanks my friend
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar