Java - FatJar no me funciona

   
Vista:

FatJar no me funciona

Publicado por Supra (36 intervenciones) el 20/04/2008 12:56:58
Hola que tal?? soy yo de nuevo mirad:

Resulta que estoy generando una aplicación con eclipse en winxp...mi aplicación utiliza unos jar de la api jogl (opengl + java)...en eclipse las añado a mi proyecto y aparecen como Referenced Libraries. Hasta aquí todo bien, ejecuto en eclipse y me sale la ventanita con mi gráfico, vamos que ejecuta correctamente. Pero quiero meterlo todo en un jar para ejecutar en cualquier pc.

Después de mucho buscar como crear el jar a partir de otro jar, encontre un plugin de eclipse llamado FatJar que te mete todo lo utilizado en tu proyecto en un solo jar. Pues lo instale y me genera el jar correctamente, con un tamaño normal. Pero al hacer doble click en el archivo...no me sale nada...abro el jar generado y estan todos los archivos utilizados en el proyecto...y con su archivo manifiest cuya estructura es la siguiente:

Manifest-Version: 1.0
Created-By: Fat Jar Eclipse Plug-In
Main-Class: MainClass
Class-Path: ./lib/jogl.jar ./lib/gluegen-rt.jar

los jars que utilizo para mi proycto los tengo metidos dentro de una carpeta llamada lib, que esta dentro de mi proyecto que se llama Jgl.

Pues bien agradeceria que alguien me explicara, por que no me ejecuta en windows el archivo jar....otros jar que no hagan referencia a otros jars si ejecutan bien...solo cuando creo jars dependientes de otros jars Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder