PHP - problema con Unicode utf-8

   
Vista:

problema con Unicode utf-8

Publicado por zendi (824 intervenciones) el 09/01/2014 15:53:31
buen dia a todos, desarrolle un reporte pero me da problemas al imprimir y aparecen estos caracteres
, en el formulario desde donde llamo el reporte he colocado este codigo:
1
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
si pueden ayudarme en esta cruzada.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

problema con Unicode utf-8

Publicado por xve (5520 intervenciones) el 09/01/2014 21:22:28
Hola Zendi, por lo que entiendo, el código esta escrito en un editor con iso-8859 y lo estas mostrando con utf-8 si en la cabecera pones:
1
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

Se ve igualmente mal?

Otra cosa que puedes hacer, es hacer un replace con los acentos, y poner los acentos en formato html...
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
á &aacute;
é &eacute;
í &iacute;
ó &oacute;
ú &uacute;
 
Á &Aacute;
É &Eacute;
Í &Iacute;
Ó &Oacute;
Ú &Uacute;
 
à &agrave;
è &egrave;
ì &igrave;
ò &ograve;
ù &ugrave;
 
À &Agrave;
È &Egrave;
Ì &Igrave;
Ò &Ograve;
Ù &Ugrave;
 
ñ &ntilde;
Ñ &Ntilde;
 
ç &ccedil;
Ç &Ccedil;
 
¿ &iquest;
 
ë &euml;

Espero que te sirvan...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

problema con Unicode utf-8

Publicado por zendi (824 intervenciones) el 09/01/2014 21:59:38
Que tal Xve. Bueno coloque la linea esta:
1
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
pero sigue igual, y en cuanto a esto:
1
á &aacute; é &eacute; í &iacute; ó &oacute; ú &uacute;
la verdad no recuerdo como aplicarlo.
Es extraño esto porque tengo otros codigos que si estan bien, y aparece el termino ´Europeo Occidental´.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

problema con Unicode utf-8

Publicado por zendi (824 intervenciones) el 10/01/2014 17:16:29
Hola Xve. Bueno no es que no sepa, miento y rectifico, lo que quiero decir es que lo estoy intentando con los acentos en html, pero no se resuelve.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar