PHP - Migrar php 5.2.3 a 5.5.x en AppServ

   
Vista:

Migrar php 5.2.3 a 5.5.x en AppServ

Publicado por Mario c macastrozafra@yahoo.com (4 intervenciones) el 11/06/2014 21:57:00
Hola a todos.

Necesito hacer migración de php 5.2 .3 a 5.5 en appserv 2.5.9 en un servidor de producción, no tengo forma de crear un mirror para actualizar sin afectar a mis usuarios, debo apagar servicios y hacer la actualización tan rápido como sea posible, podrían orientarme al respecto, facilitarme una guía o link paso a paso para actualizar PHP.

Gracias por la ayuda que me puedan brindar.


Un Saludo!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Actualizar php en AppServ de 5.2.3 a 5.5.x

Publicado por xve (5523 intervenciones) el 12/06/2014 07:43:47
Hola Mario, lo que yo haria, seria hacer las pruebas en otro pc, y si funciona correctamente, luego realizarlo en el servidor de producción...

1- Descargar la ultima versión de PHP para Windows en http://windows.php.net/download/
Selecciona la versión de 32 o 64 bits Thread Safe

2- Descomprime el archivo en una carpeta dentro de c:/appserv/

3- Guarda la versión anterior de PHP. Renombrar la carpeta php5 a php5-bak

4- Renombrar la carpeta con la nueva versión del PHP a php5

5- Tienes que reiniciar el servicio del apache...
Inicio -> Panel de Control -> Herramientas administrativas -> Servicios
Buscas el servicio apache2.2 y lo paras y inicias nuevamente.

6- Verifica con phpinfo() que dispones de la nueva versión del php

Coméntanos si te funciona, ok?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Actualizar php en AppServ de 5.2.6 a 5.5.x

Publicado por treboR (1 intervención) el 23/07/2014 21:45:33
Ya hice los pasos que comenta xve, pero al parar el servicio apache no inicia, me dice que verifique el visor de sucesos y de ahí encontré el siguiente error:
The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 205 of D:/AppServ/Apache2.2/conf/httpd.conf: Cannot load D:/AppServ/php5/php5apache2_2.dll into server: No se puede encontrar el m\xf3dulo especificado. .
Si alguien logró hacerlo, por favor, responda.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Actualizar php en AppServ de 5.2.6 a 5.5.x

Publicado por xve (5523 intervenciones) el 24/07/2014 08:20:05
Hola Trebor, es como si no estuviera instalado el php... puede ser que no lo instalaras?

Sobre que sistema operativo lo estas instalando?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Migrar php 5.2.3 a 5.5.x en AppServ

Publicado por Aníbal Álvarez anibalealvarezs@gmail.com (2 intervenciones) el 31/07/2014 15:21:07
Lo que sucede es que PHP 5.5 no trae módulo para Apache 2.2, sino únicamente para Apache 2.4.

Lo que puedes hacer (lo que yo hice con mi instalación local de AppServ), fue colocar PHP 5.4 en lugar de PHP 5.5, pues el 5.4 trae módulos para ambas versiones de Apache. Si lo que necesitas son las librerías para los "namespace", pues con esta versión ya te basta...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Migrar php 5.2.3 a 5.5.x en AppServ

Publicado por gerardode80 gerardode80@hotmail.com (1 intervención) el 03/01/2015 15:38:48
Hola Anibal, yo hice los procedimientos con php 5.4.36 , me tambien me aparece el error que el apache no puede iniciar, como puedo instalarlo, necesito la version de php5.4
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Migrar php 5.2.3 a 5.5.x en AppServ

Publicado por Jose Luis (1 intervención) el 22/04/2015 02:13:08
Hola alquien pudo solucionar este problema?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Migrar php 5.2.3 a 5.5.x en AppServ

Publicado por Alfredo (1 intervención) el 23/08/2015 00:33:21
Buenas Chicos.

Yo tenia APPSERV 2.5.10 e hice lo que posteo XVE y me funciono, el unico error fue que phpmyadmin tenia que actualizarlo y por ende al actualizar phpmyadmin me pedia actualizar el MySQL Server, y al actualizar MySQL, me pedia requisito Pyton, y luego se instalo todo lo que venia en el paquete full del MySQL. el unico problema que tube fue cuando tube que abrir el puerto 3306 en el firewall y en el antivirus.

apesar de todo ello no pude conectar el mysql con el apache, solo se que debi descargar el comprimido y crear el servicio Mysql e iniciar el ejecutable pero no pude, ya que por el tiempo preferi el camino mas largo e instale un servidor linux
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Claudio

Migrar php 5.2.3 a 5.5.x en AppServ

Publicado por Claudio (2 intervenciones) el 10/11/2015 23:59:33
Es correcto lo que mencionas. Tenía el mismo caso php 5.2.3 y AppServ 2.5.10. Baje servicios de mysql y Apache2.2.
Renombre directorio php5 como php5-bak
copie en su lugar el php5.4 TS bajado de http://windows.php.net/download#php-5.5
lo copie en \appserv\ y renombre el directorio como php5.
Reinicie servicios de apache (primero) y mysql despues.
Todo bien alli. El phpinfo() quedo con "PHP Version 5.4.45"

Gracias por tu ayuda.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Claudio

Migrar php 5.2.3 a 5.5.x en AppServ

Publicado por Claudio (2 intervenciones) el 07/12/2016 14:20:40
Un comentario adicional a partir de una pregunta que reicbi al respetco de este tema.
Finalmente la decision que tome para salir del 5.2 y hacer un verdadero upgrade de php es salir del appserv e implementar XAAMP.
Como plataforma me saco el sombrero. Como migracion llevo un rato, pero no es grave. Solo organizarse porque la base y sus configuraciones tuve que migrarlas manualmente.
El resto de los archivos de las aplicaciones fue sencillo.
Suerte con su trabajo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Migrar php 5.2.3 a 5.5.x en AppServ

Publicado por Aníbal Álvarez (2 intervenciones) el 07/12/2016 14:28:35
Efectivamente. Eso mismo hice el año pasado. Ahora trabajo con XAMPP. Me cansé de que AppServ me arroje problemas por cuestiones que deberían estar resueltas de entrada.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar