PHP - Funcion mail() me dejó de funcionar

   
Vista:

Funcion mail() me dejó de funcionar

Publicado por Juan Antonio (22 intervenciones) el 01/11/2014 19:28:58
Hola, buenas, resulta que tenía instalado el appserver 2.5.9 y la función mail me funcionaba perfectamente en localhost, luego actualicé a appserver 2.5.10 y todo me iba bien, no me di cuenta de la función mail si funcionaba o no, no sé si fue por la actualización esta o qué, también en mi php utilizaba mysql y lo cambié todo a msqli, ya no sé si es que la función mail no funciona en esta nueva versión de php o que configuré algo en su día en php.ini, por más que busco no encuentro nada, el error que me das es este:


Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\AppServ\www\LigaRevolution\paginas\contacto.php on line 110


Saludos y gracias, a ver si alguien puede ayudarme.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Funcion mail() me dejó de funcionar

Publicado por xve (5525 intervenciones) el 02/11/2014 09:17:59
Hola Juan Antonio, yo creo que no tiene nada que ver la manera en que te conectas a la base de datos con que no se pueda conectar a tu servidor de correo...

Has revisado los valores en el php.ini que estén correctamente?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Funcion mail() me dejó de funcionar

Publicado por Juan Antonio (22 intervenciones) el 02/11/2014 10:29:20
Hola, buenas, creo que tiene que ser algo de eso del archivo php.ini-recommended que está dentro de la carpeta php5, también está el archivo php.ini-dist, en su día cuando tenía instalado la versión anterior de php4 ya me costó lo suyo que funcionará, no sé como no guarde por ahí lo que tuve que tocar, en los dos .ini tengo esto:

[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

; For Win32 only.
;sendmail_from = me@example.com

Saludos y gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Funcion mail() me dejó de funcionar

Publicado por Juan Antonio (22 intervenciones) el 03/11/2014 23:54:45
Nada, no consigo que funcione, no sé que me falta por configurar, me sigue saliendo el mismo error.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar