PHP - No funciona include o require en el servidor pero sí en local

   
Vista:

No funciona include o require en el servidor pero sí en local

Publicado por Dio (15 intervenciones) el 31/08/2015 06:00:49
Por alguna razón, en local me funciona perfecto y cuando lo pongo en el servidor (sin aparecerme ningún error) no se muestra nada a partir del include... probé copiando el texto del archivo que pongo en el include y no me da problemas...
Lo raro es que el primer include, el de header me lo toma, el segundo no.

1
2
3
4
5
6
7
8
<?php
 
	$reportes = true;
	include 'header.php';
 
	$sesion = new Sessiones();
    $sesion->bloquearPaginaReportes();
	include 'class.abm_usuarios.php';

Esta es la clase que tomo en el include que no me funciona
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
class Usuarios
	{
 
		function mostrarUsuarios()
		{
			$conn = Conection::conexion();
			$sql = "EXEC sp_get_all_users";
			$stmt = sqlsrv_query( $conn, $sql );
 
			$i = 0;
	        $listaUsuarios = array();
	        while( $row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_ASSOC) ) {
	        	$misUsuarios = new Usuarios();
 
	        	$misUsuarios->id = $row['cod_usuario'];
	        	$misUsuarios->credencialita = $row['credencial'];
	            $misUsuarios->nombre = utf8_encode($row['txt_nombre']);
	            $misUsuarios->email = utf8_decode($row['txt_email']);
	            $misUsuarios->cant_puntos = $row['cant_puntos'];
	            if ($row['sn_activo'] == -1) {$misUsuarios->activo ='Si';}else{$misUsuarios->activo ='No';}
	            $misUsuarios->rol = utf8_encode($row['tipoUsuario']);
	            $misUsuarios->agencia = utf8_encode($row['empresa'] );
 
	            $listaUsuarios[$i] = $misUsuarios;
	            $i++;
			}
			Conection::CerrarConexion($conn);
			return $listaUsuarios;
	    	//echo json_encode($listaUsuarios);
		}
 
		function mostrarUsuarioEspecifico($id)
		{
			$conn = Conection::conexion();
			$sql = "EXEC sp_get_user_especifico @id=".$id;
			$stmt = sqlsrv_query( $conn, $sql );
 
			$row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_ASSOC );
 
			$miUsuario = array(
					 	'credencial' => utf8_encode( $row['credencial']  )
						, 'rol' => utf8_encode( $row['tipoUsuario'] )
						, 'nombre' => utf8_encode( $row['txt_nombre'] )
						, 'email' => $row['txt_email']
						, 'agencia' => utf8_encode( $row['empresa'] )
						, 'codAgencia' => $row['cod_empresa']
						, 'codRol' => $row['cod_tipo_usuario']
						, 'codUsuario' => $row['cod_usuario']
						);
			Conection::CerrarConexion($conn);
			return $miUsuario;
		}
 
		function editUsuario($id, $credencial, $rol, $nombre, $mail, $empresa)
		{
			include 'class.conection.php';
			$conn = Conection::conexion();
			$sql = "EXEC sp_upd_user @id=".$id.",
					@credencial = '".$credencial."' ,
					@txt_nombre = '".$nombre."' ,
					@txt_email = '".$mail."' ,
					@cod_tipo_usuario = ".$rol." ,
					@cod_empresa = ".$empresa
					;
			$stmt = sqlsrv_query( $conn, $sql );
//echo json_encode($sql);
			$rows_affected = sqlsrv_rows_affected( $stmt);
			if( $rows_affected === false) {
			     die( print_r( sqlsrv_errors(), true));
			} elseif( $rows_affected == -1) {
			      echo "Eror 1";
			} else {
			      echo $rows_affected."Query bien efectuada";
			}
			Conection::CerrarConexion($conn);
		}
 
		function agregarUsuario($credencial, $rol, $nombre, $mail, $empresa)
		{
			include 'class.conection.php';
			$conn = Conection::conexion();
				$sql = "EXEC sp_ins_usuario
					  @credencial = '".$credencial."'
					, @cod_tipo_usuario = ".$rol."
					, @cod_empresa = ".$empresa."
					, @txt_nombre = '".$nombre."'
					, @txt_mail = '".$mail."' ";
 
				$stmt = sqlsrv_query( $conn, $sql );
 
				//Email::mandar_mail_alta($id, $usuario, $email, $password, $documento, $nombre, $apellido, $id_agencia, $rol);
				$rows_affected = sqlsrv_rows_affected( $stmt);
				if( $rows_affected === false) {
				     die( print_r( sqlsrv_errors(), true));
				} elseif( $rows_affected == -1) {
				      echo json_encode( "Error 1");
				} else {
				      echo json_encode( "Agregado correctamente");
				}
 
				Conection::CerrarConexion($conn);
		}
 
		function deleteUsuario($id)
		{
 
		}
 
		function desbloquearUsuario($id)
		{
			include 'class.conection.php';
			$conn = Conection::conexion();
			$sql = "EXEC sp_desbloquear_usuario @id =".$id;
			$stmt =sqlsrv_query( $conn, $sql );
 
			//Email::mandar_mail_desbloqueo($id);
 
			$rows_affected = sqlsrv_rows_affected( $stmt);
			if( $rows_affected === false) {
			     die( print_r( sqlsrv_errors(), true));
			} elseif( $rows_affected == -1) {
			      echo json_encode( "Error 1");
			} else {
			      echo json_encode( "Desbloqueado correctamente");
			}
			Conection::CerrarConexion($conn);
		}
		function bloquearUsuario($id)
		{
			include 'class.conection.php';
			$conn = Conection::conexion();
			$sql = "EXEC sp_bloquear_usuario @id =".$id;
			$stmt =sqlsrv_query( $conn, $sql );
 
			//Email::mandar_mail_bloqueo($id);
 
			$rows_affected = sqlsrv_rows_affected( $stmt);
			if( $rows_affected === false) {
			     die( print_r( sqlsrv_errors(), true));
			} elseif( $rows_affected == -1) {
			      echo json_encode( "Error 1");
			} else {
			      echo json_encode( "Bloqueado correctamente");
			}
			Conection::CerrarConexion($conn);
		}
 
		function getAgencias()
		{
			$conn = Conection::conexion();
			$sql = 'EXEC sp_get_empresas';
			$stmt = sqlsrv_query( $conn, $sql );
 
			$i = 0;
			$misAgencias = array();
			while ($row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_ASSOC) )
			{
				$misAgencias[$i] = [ $row['CodEmpresa'] => utf8_encode($row['Empresa']) ];
				$i++;
			}
			return $misAgencias;
			Conection::CerrarConexion($conn);
		}
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

No funciona include o require en el servidor pero sí en local

Publicado por Jon hi@jon.soy (1 intervención) el 31/08/2015 08:31:17
Revisa la version de PHP de tu servidor, puede que no sea distinta con la de tu version local.

de ser el caso solo consulta la documentación de la version de tu servidor.
o en caso de usar CPANEL puede especificar la version a utilizar.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No funciona include o require en el servidor pero sí en local

Publicado por Dio (15 intervenciones) el 31/08/2015 17:16:04
No es la misma, me fijé, pero no uso nada raro ni nada que no haya usado antes y ya funciona
En local uso php 5.6.1 y en el server tengo 5.3
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No funciona include o require en el servidor pero sí en local

Publicado por FoxCom (1 intervención) el 31/08/2015 10:19:37
Si estas usando un servidor Linux en remoto y un sevidor Windows en local podría ser que el archivo no tenga los permisos adecuados para ejecutarse desde el servidor remoto. revisa los permisos del archivo desde linux por si acaso.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No funciona include o require en el servidor pero sí en local

Publicado por Dio (15 intervenciones) el 31/08/2015 12:55:35
En los dos casos tengo Windows por el motor de base de datos que uso que es Windows server. Lo raro es que me cargue todos los include y require menos este. Para mí es algo de código pero no logro entenderlo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Vainas

No funciona include o require en el servidor pero sí en local

Publicado por Vainas (254 intervenciones) el 31/08/2015 14:53:09
Ponle un require en vez de un include y activa los errores a ver que pasa.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No funciona include o require en el servidor pero sí en local

Publicado por Dio (15 intervenciones) el 31/08/2015 17:15:27
También probé con require, require_once y include_once... Y es un server que no me deja activar mensajes de error
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar