Código de Pseudocódigo/Diagramas de Flujo - Programa que permita gestionar los gastos de "n" días de una persona

Imágen de perfil
Val: 17
Ha mantenido su posición en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Programa que permita gestionar los gastos de "n" días de una personagráfica de visualizaciones


Pseudocódigo/Diagramas de Flujo

Publicado el 1 de Junio del 2018 por Geraldine
1.089 visualizaciones desde el 1 de Junio del 2018
Implementar un programa que permita gestionar los gastos de "n" días de una persona. Se deberá mostrar el total de gastos y que día se hizo el mayor gasto.

Requerimientos

Requiere descargar PSeInt para poder ejecutar el código.

2018

Publicado el 1 de Junio del 2018gráfica de visualizaciones de la versión: 2018
1.090 visualizaciones desde el 1 de Junio del 2018
estrellaestrellaestrellaestrellaestrella
estrellaestrellaestrellaestrella
estrellaestrellaestrella
estrellaestrella
estrella

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
Proceso DiaPagoMayor
	//Variables:
	Definir gastoMayor, gastoTotal, cantDias, cont Como Entero
	gastoMayor<-0
	gastoTotal<-0
	dias<-0
	aux<-1//Decimos que el aux=1 para que comience en el vector 1, el cual esta identificado como el dia "lunes"
 
	//Ingresamos los datos:
	Escribir 'Ingrese la cantidad de dias'
	Leer cantDias
	Escribir ''
 
	//Declaramos los vectores:
	Dimension vector[cantDias] //Este vector almacena 
	Dimension strDias[7]
	strDias[1] <- 'lunes'
	strDias[2] <- 'martes'
	strDias[3] <- 'miercoles'
	strDias[4] <- 'jueves'
	strDias[5] <- 'viernes'
	strDias[6] <- 'sabado'
	strDias[7] <- 'domingo'
 
	//Creamos un ciclo que al llegar a 7 vuelva a empezar hasta que termine de llenar la cantidad de dias establecidos
	Para i<-1 Hasta cantDias Hacer
 
		//Cuando aux=8 el aux comenzara de nuevo en 1, este aux lo introducimos en el corchete de strDias[] para que 
		//indique el dia 
		Si aux=8 Entonces
			aux<-1
		Fin Si
 
		//Ingresamos los datos:
		Escribir 'Ingrese los gastos del dia ',strDias[aux],':'
		Leer vector[i]
		aux<-aux+1
		cont<-aux-1
	Fin Para
 
	//Calculamos el gasto total de 'n' cantidad de dias:
	Para i<-1 Hasta cantDias Hacer
		gastoTotal<-gastoTotal+vector[i]
	Fin Para
 
	//Calculamos el mayor gasto: 
	Para i<-1 Hasta cantDias Hacer
		Si vector[i]>gastoMayor Entonces
			gastoMayor<-vector[i]
			dias<-i
		Fin Si
	Fin Para
 
	Escribir ''
	Escribir 'El mayor gasto fue de ', gastoMayor, ' del dia ',strDias[dias]
	Escribir 'El gasto total fue de: ',gastoTotal
 
FinProceso



Comentarios sobre la versión: 2018 (0)


No hay comentarios
 

Comentar la versión: 2018

Nombre
Correo (no se visualiza en la web)
Valoración
Comentarios
Es necesario revisar y aceptar las políticas de privacidad

http://lwp-l.com/s4632