Código de Pseudocódigo/Diagramas de Flujo - Llenar un array multidimensional y sumar sus valores

Imágen de perfil

Llenar un array multidimensional y sumar sus valoresgráfica de visualizaciones


Pseudocódigo/Diagramas de Flujo

Publicado el 22 de Octubre del 2019 por Administrador
455 visualizaciones desde el 22 de Octubre del 2019
Crea un arreglo o array multidimensional que contenga 3 columnas y las filas que tu quieras, las dos primeras columnas tendrán números y en la 3 columna sera el resultado de sumar el número de la primera y segunda columna

pseint-sumar-array-mutidimensional

Requerimientos

PSeInt

20180110

Publicado el 22 de Octubre del 2019gráfica de visualizaciones de la versión: 20180110
456 visualizaciones desde el 22 de Octubre del 2019
estrellaestrellaestrellaestrellaestrella
estrellaestrellaestrellaestrella
estrellaestrellaestrella
estrellaestrella
estrella


Forma parte de DDR
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
SubProceso  mostrarArray ( num, FILAS )
 
    Para i<-1 Hasta FILAS Con Paso 1 Hacer
        escribir num[i,1]," + ",num[i,2]," = ",num[i, 3]
    Fin Para
Fin SubProceso
 
Proceso Ejercicio8
 
    //Declaramos variables
    Definir num como entero
    Definir FILAS como entero
    Definir COLUMNAS Como Entero
 
    //Definimos las fila del array por teclado, las columnas 
    //ya sabemos que siempre seran 3    
    escribir "Introduce las filas del array multidimensional"
    leer FILAS
    COLUMNAS<-3
 
    //Definimos el array
    Dimension num[FILAS, COLUMNAS]
 
    //Introducimos los nombres y la longitud de los mismos  
 
    Para i<-1 Hasta FILAS Con Paso 1 Hacer
        Para j<-1 Hasta COLUMNAS Con Paso 1 Hacer
            //Cuando j llegue a 3 (donde debemos sumar), sumara los valores anteriores,
            //esto permite que nos ahorremos despues un bucle
            si (j=COLUMNAS) Entonces
                num[i,j]<-num[i,1]+num[i,2]
            Sino
                Escribir "Introduce un numero para la FILA ",i," COLUMNA ",j
                leer num[i,j]
            FinSi
        Fin Para
    Fin Para
 
    //Invocamos la función  
    mostrarArray( num, FILAS)
 
FinProceso



Comentarios sobre la versión: 20180110 (0)


No hay comentarios
 

Comentar la versión: 20180110

Nombre
Correo (no se visualiza en la web)
Valoración
Comentarios
Es necesario revisar y aceptar las políticas de privacidad

http://lwp-l.com/s5600