Excel - Copiar valor celda de una tabla a otra si coincide valor de A con D

 
Vista:

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por JOEL (2 intervenciones) el 05/04/2018 08:31:38
Buenas! llevo tiempo sin utilizar las formulas de Excel y no me acuerdo cómo hacerlo...

Tengo dos tablas, la 1ra con 3 columnas (A,B y C) y la 2nda con 2 (D y E). Quiero Copiar el valor de la columna E a la columna C cuando coincidan el valor de A y D. No se si me he explicado bien


Gracias! un saludo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 4.154
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Antoni Masana (1459 intervenciones) el 05/04/2018 08:47:03
Formula en la celda C1

1
=SI(A1=D1;E1;"")

Y la arrastras al resto de la columna.

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por JOEL (2 intervenciones) el 05/04/2018 09:03:29
Pero asi funciona para el primero porque lo introduces manual, pero para las siguientes columnas no funciona o aparece "FALSO" ya que el segundo valor de la columna no coincide con el de la otra tabla

Es decir, quiero que en la columna c se copien los datos si coincide el numero de A con alguno de la tabla 2
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antoni Masana
Val: 4.154
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Antoni Masana (1459 intervenciones) el 05/04/2018 11:29:17
Por favor sube un fichero de ejemplo.

La propuesta anterior es como sigue:

Fórmula en la celda C1 =SI(A1=D1 ; E1 ; "" )
Fórmula en la celda C2 =SI(A2=D2 ; E2 ; "" )
Fórmula en la celda C3 =SI(A3=D3 ; E3 ; "" )

Con esta fórmula no sale FALSO porque si no se cumple la condición pone un NULO ( "" ).
La condición se cumple cuando A y D son iguales en la misma fija.

Otra cosa es que las condiciones sean diferentes.

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 18
Ha disminuido su posición en 3 puestos en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Antonio (10 intervenciones) el 05/04/2018 14:08:24
Buenos días Antoni,
A mi me pasa algo parecido, lo único es que si hay coincidencia de los datos de la columna 1 con la 2, lo que quiero es que devuelva por ejemplo a una columna 6 el valor de fecha_hoy, por cada registro que coincida.
Es esto posible?
Muchas gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Andres Leonardo
Val: 3.826
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Andres Leonardo (1419 intervenciones) el 05/04/2018 15:01:41
En la celda 6 coloca esto

1
=SI(A2=B2,HOY(),"")


Luego arrastras

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 18
Ha disminuido su posición en 3 puestos en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Antonio (10 intervenciones) el 05/04/2018 15:07:07
Muchas gracias, ahora lo pruebo y te comento
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 18
Ha disminuido su posición en 3 puestos en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Antonio (10 intervenciones) el 05/04/2018 15:39:56
no lo consigo, soy un torpe
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 18
Ha disminuido su posición en 3 puestos en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Antonio (10 intervenciones) el 05/04/2018 15:49:50
No lo consigo, algo debo estar haciendo mal
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Ignacio
Val: 715
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Ignacio (205 intervenciones) el 05/04/2018 16:00:53
Hola:

Sube tu archivo o una muestra con las formulas que estas utilizando para checar...

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 18
Ha disminuido su posición en 3 puestos en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Antonio (10 intervenciones) el 05/04/2018 16:26:34
Te mando un ejemplo de lo que quiero hacer, que es como debería de quedar.
si las celdas de la columna 1 coincide con las celdas de la columna 2, que devuelva la fecha de hoy en la columna 6.
Esta claro que serán en la columna 1 cerca de 1000 registros, y en la columna 2, unos 12000 registros.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Ignacio
Val: 715
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Ignacio (205 intervenciones) el 05/04/2018 16:39:44
No veo ningún problema, con la formula que te dio Andres Leonardo funciona, tal vez el problema sea el separador de argumentos, Andres utiliza la "," quizá el tuyo sea ";"

1
=SI(A2=B2;HOY();"")


Una pregunta.. La fecha que te va a poner es la de ahora, pero mañana que vuelvas a abrir el archivo te la va a cambiar, si así lo quieres esta bien, pero si lo que quieres es conservar la fecha del día en que las dos columnas coincidieron, entonces eso no te va a servir..
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil
Val: 18
Ha disminuido su posición en 3 puestos en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Antonio (10 intervenciones) el 05/04/2018 17:05:31
Muchas gracias, ahora si funciona
Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antoni Masana
Val: 4.154
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Copiar valor celda de una tabla a otra si coincide valor de A con D

Publicado por Antoni Masana (1459 intervenciones) el 06/04/2018 06:41:46
Hay un pequeño detalle a tener en cuenta.

Con la fórmula que te cuenta Ignacio ayer cuando lo probaste el la celda pone 04/04/2018 pero si abres el libro hoy pondrá 05/04/2018.

CUIDADO porque puede no ser lo que deseas.

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar