PDF de programación - OSPF

Imágen de pdf OSPF

OSPFgráfica de visualizaciones

Actualizado el 16 de Junio del 2017 (Publicado el 27 de Abril del 2017)
550 visualizaciones desde el 27 de Abril del 2017
115,0 KB
5 paginas
Creado hace 15a (15/10/2004)
Lab 4: Routing Dinámico - OSPF

José Mª Barceló Ordinas

1. OSPF

1.1. Configuración básica en un área

Para configurar el algoritmo de encaminamiento OSPF en un área (por ejemplo el área 0), los pasos a
seguir son los siguientes:



RC

Area 0

10.0.3.0/24

T3

200.0.1.0/24

Consola

T1

RA

10.0.1.0/24

10.0.2.0/24

T2

RB


Usamos el comando “router ospf process-id” para crear un proceso OSPF en el router. “process-
id” es un identificador del proceso OSPF para el caso de que haya múltiples procesos OSPF ejecutándose
en el router y es un número escogido por el administrador del sistema. Para indicar las redes que se deben
anunciar se usa el comando “network NetID WildcardMask area area-id”. El comando
“network” indica las interfaces que van a enviar o procesar mensajes de encaminamiento.



RA# configure terminal
RA(config)# ip routing
RA(config)# router ospf 1
RA(config-router)# network 200.0.1.0 0.0.0.255 area 0
RA(config-router)# network 10.0.1.0 0.0.0.255 area 0
RA(config-router)# ^Z
RA# show ip route


Verificación del funcionamiento de OSPF. Usar los siguientes comandos:


show ip protocols: permite ver que protocolos de encaminamiento hay activos listando parámetros
tales como temporizadotes, métricas, filtros, etc
show ip route: permite ver la tabla de encaminamiento
show ip route ospf: permite ver la tabla de encaminamiento solo para entradas OSPF
show ip ospf interface: lista información relacionada con una interfaz que usa OSPF. Permite
comprobar si las interfaz pertenecen al área a la que se suponen deberían pertenecer. Tambien
permite averiguar si una interfaz es DR, BDR o DROTHER (no es ni DR ni BDR), su prioridad y
si la red es de tipo BMA o NBMA.
show ip ospf: lista el número de veces que el algoritmo SPF (Short-First Path) se ha ejecutado
show ip ospf neighbor: lista información acerca de los vecinos OSPF por cada interfaz
show ip ospf neighbor: lista información detallada acerca de los vecinos OSPF por cada interfaz
show ip ospf database: lista los contenidos de la DB topológica
debug ip ospf “op”: donde “op” son distintas opciones permiten debuguear la distintas
operaciones que ejecuta OSPF (adjacency, events, etc)



1

Lab 4: Routing Dinámico - OSPF

José Mª Barceló Ordinas

1.2. Modificación del comportamiento de OSPF

Cada router escoge como OSPF Router ID la dirección IP mayor. Si la interfaz que tiene esa interfaz cae,
debe cambiar el OSPF router ID, cosa que puede afectar a la elección del DR y BDR. Para evitar este
efecto, se suele configurar siempre una interfaz loopback con una dirección IP que no tiene por que estar en
el rango 127.0.0.0/8.

Podemos modificar también la prioridad de un router con el comando “ip ospf priority number”,
donde “number” es un número entre 1 y 255. Prioridad 0 implica que el router no puede ser elegido DR o
BDR, el valor por defecto es 1 y a mayor valor el router es elegido como DR o BDR.

La métrica por defecto usada en OSPF es el ancho de banda. En un router CISCO el coste de un enlace se
calcula como 108‚ bandwidth (bps). Por ejemplo si tenemos un enlace Ethernet a 10 Mbps el coste sería
108‚ 107=10, mientras que un modem a 56 Kbps tendria un coste de 108‚ 56*103=1785. El SPF es un
algoritmo de mínimo coste. Podemos modificar el coste de un enlace de dos maneras: (1) modificando el
valor del coste en la interfaz de ese enlace con el comando “ip ospf cost” donde cost tiene un valor
entre 1 y 65535 o (2) modificando el valor del bandwidth en la interfaz que permite calcular el coste con el
comando “bandwidth value”. Fijaros que NO estáis cambiando la velocidad real del enlace, solo el
coste de cara a calcular el camino más corto.

Se pueden cambiar los valores de periodicidad de los temporizadores de paquetes Hello: hello-interval
(tiempo entre paquetes hello, por defecto es 10 s) y dead-interval (tiempo que considera que el enlace ha
caído, por defecto es 40 s). Los temporizadores se modifican por interfaz con los comandos “ip ospf
hello-interval value” y “ip ospf dead-interval value”


RA(config)# interface loopback 0
RA(config-if)# ip address 172.5.5.2 255.255.255.0
RA(config-if)# exit
RA(config)# interface s0
RA(config-if)# bandwidth 2048000 2,048 Mbps
RA(config-if)# ip ospf cost 488 equivalente al comando anterior
RA(config-if)# ip ospf hello-interval 30
RA(config-if)# ip ospf dead-interval 120
RA(config-if)# ^Z
RA#

1.3. Configuración en áreas múltiples

Para configurar el algoritmo de encaminamiento OSPF en más de un área los pasos a seguir son los
siguientes:



RC

Area 30

10.0.3.0/24

T3

Area 0

200.0.1.0/24

T1

Area 10

RA

10.0.1.0/24

RB

10.0.2.0/24

Area 20

T2



2



Lab 4: Routing Dinámico - OSPF

José Mª Barceló Ordinas

Si hay más de un área, siempre debe haber un área 0 que haga de backbone. Debemos configurar el área de
backbone (área 0) y a continuación el resto de áreas (diseño jerárquico). A las rutas que se generan dentro
de un área se les llama intra-area-routes y aparecerán en la tabla de encaminamiento identificadas con la
letra O. A las rutas aprendidas de otra área se les llama inter-area-routes o summary-routes y aparecerán
en la tabla de encaminamiento identificadas con la letra O IA. A las rutas inyectadas desde otros protocolos
de encaminamiento (usando redistribución de rutas) se les llama external-routes y aparecerán en la tabla
de encaminamiento identificadas con la letra O E1 (tipo 1 significa que el coste es la suma del protocolo
interno más el externo) o O E2 (tipo 2 significa que el coste es siempre el del protocolo externo). Por
defecto OSPF siempre redistribuye con tipo 2.


RA(config)# interface e0
RA(config-if)# ip address 10.0.1.1 255.255.255.0
RA(config-if)# no shutdown
RA(config-if)# exit
RA(config)# interface e1
RA(config-if)# ip address 200.0.1.1 255.255.255.0
RA(config-if)# no shutdown
RA(config-if)# exit
RA(config)# router ospf 100
RA(config-router)# network 200.0.1.0 0.0.0.255 area 0
RA(config-router)# network 10.0.1.0 0.0.0.255 area 10
RA(config-router)# ^Z
RA# show ip route

1.4. Redistribución de rutas

Es posible tener zonas que usan protocolos de encaminamiento distintos. Por ejemplo OSPF y RIPv2. Hay
que inyectar las rutas que se aprenden de un protocolo a otro. A este proceso se la llama “redistribución de
rutas”. Lo lógico es que en una red corra un único protocolo de encaminamiento, pero imaginar que se
unen dos redes con protocolos distintos y tienen que convivir (e.g.; pueden incluso estar administrados por
distintos departamentos).

El punto más importante es que las métricas de los protocolos son distintas: RIPv2 usa saltos (“hops”) y
OSPF usa “bandwidth”.

OSPF: su métrica es bandwidth y usa costes con la fórmula 108‚ bandwidth (bps). OSPF pone como coste
igual a 20 por defecto al protocolo redistribuido (excepto BGP que le pone coste igual a 1). Como anuncia
redes principales hay que añadir el parámetro subset para indicar que la red está subneteada.

RIPv2: como la métrica son los saltos se recomienda usar como métrica por defecto un valor bajo (e.g.; 1
salto)

Hay que tener cuidado en que un protocolo de encaminamiento (e.g.; RIPv2) no le devuelva a redistribuir
rutas que OSPF le ha anunciado (e.g.; 10.0.1.0/24) o viceversa. Para ello hay que crear Listas de Acceso
(ACLs) que eviten realimentaciones (formando un bucle). En realidad no siempre es necesario crear la lista
de acceso ya que la distancia administrativa en RIPv2 es mayor que en OSPF y las entradas OSPF siempre
tienen precedencia sobre RIP en la tabla de encaminamiento. Eso significa que realimentaciones de OSPF
hacia RIP deben estar filtradas con ACLs y realimentaciones de RIP hacia OSPF no serían necesario
controlarlas.

En el caso de que queramos redistribuir una ruta estática se usa el comando “redistribute static”.


RB(config)# router ospf 100
RB(config-router)# network 11.0.1.0 0.0.0.255 area 0
RB(config-router)# redistribute static
RB(config-router)# exit



3

Lab 4: Routing Dinámico - OSPF

José Mª Barceló Ordinas



LA redistribución de rutas estáticas nos puede servir para redistribuir en nuestra red la red de salida por
defecto (el gateway de salida a nuestro ISP). Hay varias formas de hacerlo.

Primero hay que definir una ruta estática al gateway por defecto usando el comando “ip route Ipred Mask
@IPgw”. A continuación hay dos formas:


o Redistribución estática de la ruta con el comando “redistribuye static” que inyecta todas las rutas

estáticas en el protocolo dinámico (e.g.; OSPF)

o Usar el comando “default-information originate always” para OSPF que propaga una ruta por

defecto en el dominio OSPF



2. Zebra
GNU Zebra es un software de libre distribución que gestiona protocolos de encaminamiento TCP/IP
(RIPv1v2, OSPFv2, BGPv4). El diseño de zebra está basado en modularidad y ejecuta un proceso para
cada protocolo de encaminamiento (daemon). Cada daemon (ripd, ospfd, bgpd, zebra) tiene su propio
fichero de configuración y su interfaz de configuración de terminal. Eso significa que cuando configuras
direcciones IP, rutas estáticas, etc tienes que acceder al daemon “zebra”, cuando configuras comandos de
RIP tienes que acceder al daemon de ripd, etc.

Zebra emula los comandos de CISCO para protocolos de encaminamiento, de forma que quitando algunas
pequeñas diferencias, para configurar OSPF o RIP o BGP se ejecutan los mismos comandos que el IOS de
CISCO. De esta forma, cada PC linux se convierte en un PC router con encaminamiento controlado con
comandos similares al IOS.

Aparte tenéis los comandos Zebra.

En el laboratorio, los PC linux activ
  • Links de descarga
http://lwp-l.com/pdf3223

Comentarios de: OSPF (0)


No hay comentarios
 

Comentar...

Nombre
Correo (no se visualiza en la web)
Valoración
Comentarios
Es necesario revisar y aceptar las políticas de privacidad