Java - Problema al instalar el conector apache

   
Vista:

Problema al instalar el conector apache

Publicado por carsoma (1 intervención) el 19/07/2012 17:33:50
Tengo un servidor en OVH, con el parallel plesk.

He instalado el Tomcat siguiendo estos pasos:

• yum update; yum upgrade; yum install nano;
• yum install java-1.6.0-openjdk.x86_64 -y
• java -version [Para comprobar la correcta instalación]
java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.4) (rhel-1.42.1.10.4.el6_2-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)
• wget http://apache.rediris.es/tomcat/tomcat-7/v7.0.23/bin/apache-tomcat-7.0.23.tar.gz
• tar xvzf apache-tomcat-7.0.23.tar.gz
• mv apache-tomcat-7.0.23 /usr/tomcat7
• useradd -d /usr/tomcat7 tomcat
// useradd: warning: the home directory already exists.
// Not copying any file from skel directory into it.
• chown -R tomcat. /usr/tomcat7 [Importante el punto]
• nano /etc/rc.d/init.d/tomcat7 (o, si es con el vi: sudo vi /etc/rc.d/init.d/tomcat7)


#!/bin/bash

# Tomcat7: Start/Stop Tomcat 7
#
# chkconfig: - 90 10
# description: Tomcat is a Java application Server.

. /etc/init.d/functions
. /etc/sysconfig/network

CATALINA_HOME=/usr/tomcat7
TOMCAT_USER=tomcat
LOCKFILE=/var/lock/subsys/tomcat

RETVAL=0
start(){
echo "Starting Tomcat7: "
su - $TOMCAT_USER -c "$CATALINA_HOME/bin/startup.sh"
RETVAL=$?
echo
[ $RETVAL -eq 0 ] && touch $LOCKFILE
return $RETVAL
}

stop(){
echo "Shutting down Tomcat7: "
$CATALINA_HOME/bin/shutdown.sh
RETVAL=$?
echo
[ $RETVAL -eq 0 ] && rm -f $LOCKFILE
return $RETVAL
}

case "$1" in
start)
start
;;
stop)
stop
;;
restart)
stop
start
;;
status)
status tomcat
;;
*)
echo $"Usage: $0 {start|stop|restart|status}"
exit 1
;;
esac
exit $?
• chmod 755 /etc/rc.d/init.d/tomcat7
• /etc/rc.d/init.d/tomcat7 start
Starting Tomcat7:
Using CATALINA_BASE: /usr/tomcat7
Using CATALINA_HOME: /usr/tomcat7
Using CATALINA_TMPDIR: /usr/tomcat7/temp
Using JRE_HOME: /usr
Using CLASSPATH: /usr/tomcat7/bin/bootstrap.jar:/usr/tomcat7/bin/tomcat-juli.jar
• chkconfig --add tomcat7
• chkconfig tomcat7 on
• nano /usr/tomcat7/conf/tomcat-users.xml
<?xml version='1.0' encoding='utf-8'?>

<tomcat-users>
<role rolename="manager-gui"/>
<user username="usuario" password="contrasena" roles="manager-gui"/>
</tomcat-users> [COMPROBAR QUE ESTE PASO ES REALMENTE NECESARIO, cuando haya tiempo]
• /etc/rc.d/init.d/tomcat7 restart
• Accede a: http://IP:8080


Y el tomcat se instala correctamente!!


Pero al instalar el conector apache... sigo estos pasos:

• yum install http* gcc*
• wget http://apache.rediris.es//tomcat/tomcat-connectors/jk/tomcat-connectors-1.2.32-src.tar.gz
• tar xvzf tomcat-connectors-1.2.32-src.tar.gz
• cd tomcat-connectors-1.2.32-src
• cd native
• ./configure --with-apxs=/usr/sbin/apxs
• make
• libtool --finish /usr/lib64/httpd/modules
• cp ./apache-2.0/mod_jk.so /usr/lib64/httpd/modules/
• nano /etc/httpd/conf.d/mod_jk.conf
LoadModule jk_module modules/mod_jk.so
JkWorkersFile /etc/httpd/conf/workers.properties
JkLogFile /var/log/httpd/mod_jk.log
JkLogLevel error
• nano /etc/httpd/conf/workers.properties
workers.tomcat_home=/usr/tomcat7
workers.java_home=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64
ps=/
worker.list=default
worker.default.port=8009
worker.default.host=localhost
worker.default.type=ajp13
worker.default.lbfactor=1
• /etc/init.d/httpd restart
• apachectl -t -D DUMP_MODULES
• mkdir /var/www/dominio
• mkdir /var/www/dominio/public_html
• mkdir /var/www/dominio/logs
• nano /etc/httpd/conf/httpd.conf
<virtualhost dominio.es>
JkMount /*.jsp default
ServerName dominio.es
ServerAlias www.dominio.es
ServerAdmin admin@dominio.es
DocumentRoot /var/www/dominio/public_html
ErrorLog /var/www/dominio/logs/error.log
CustomLog /var/www/dominio/logs/access.log common
JkLogFile /var/www/dominio/logs/jk.log
<directory /var/www/dominio/public_html>
Options -Indexes
</directory>
DirectoryIndex index.jsp index.html index.php
</virtualhost>
• nano /usr/tomcat7/conf/server.xml
<Host name="dominio.es" appBase="/var/www/dominio" unpackWARs="true" autoDeploy="true">
<Context path="" docBase="public_html" debug="0" reloadable="true"/>
<Valve className="org.apache.catalina.valves.AccessLogVal ve" directory="/var/www/dominio/logs" prefix="tomcat_access_" suffix=".log" pattern="common" resolveHosts="false"/>
<Alias>www.dominio.es</Alias>
</Host>
• /etc/init.d/httpd restart; /etc/init.d/tomcat7 restart;
• nano /var/www/dominio/public_html/index.jsp
<html>
<head>
<title>Hola Mundo en JSP</title>
<%!
String mensaje = "Hola Mundo! Tu servidor en JSP funciona correctamente ;)";
%>
</head>

<body>
<hr color="#000000" />
<center>
<h2><font color="#3366cc"><%= mensaje%></font></h2>
<h3><font color="#0000ff"><%= new java.util.Date() %> </font></h3>
<hr color="#000000" />
</center>
</body>
</html>
• Accede a: http://dominio.es para ver tu web





El problema está que en el paso /etc/init.d/httpd restart se para el httpd pero no se vuelve a iniciar y me da el siguiente error:

-JkWorkersFile only allowed once



Es muy importante, y he probado muchas cosas, alguien me puede dar alguna posible solución??


Muchas Gracias!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder