Java - JSP carga correctamente en Windows pero no en Linux

   
Vista:

JSP carga correctamente en Windows pero no en Linux

Publicado por Oscar (3 intervenciones) el 16/07/2015 21:03:45
Buenas tardes,
De antemano, gracias por la ayuda que me puedan brindar.
Tengo el siguiente entorno de desarrollo:
Windows 7 x64
Netbeans
JDK 8 u11
Tomcat 8

Mi ambiente de producción:
RHEL 6
JDK 8 u11
Tomcat 8

Tengo un formulario en JSP que registra datos en Oracle mediante un Servlet. Tras realizar la inserción, el Servlet envía un parámetro a otro JSP que contiene la segunda parte del formulario. Cuando se ejecuta en Windows, el segundo JSP se muestra correctamente y completo, pero cuando se ejecuta en Linux, el segundo JSP no se muestra completo, pareciendo que no carga toda la información del mismo por algún motivo.
La parte importante del del servlet es el siguiente:

1
2
3
4
5
6
7
8
if(daoficha.registrarFicha(ficha).equals("OK")){
                           request.setAttribute("numdoc", numdoc);
                           request.getRequestDispatcher("rempleado01.jsp").forward(request, response);
                           //out.println("<script>document.location.href ='../sisrh/rempleado01.jsp'</script>");
                       }else{
                           out.println("<script>alert('Se ha producido un error al registrar la Ficha')</script>");
                           out.println("<script>document.location.href ='../sisrh/rempleado.jsp'</script>");
                       }

En windows, se ejecuta bien y muestra el segundo JSP:
28tcbrk

En RHEL, muestra el segundo JSP incompleto:
mmcutv

Alguien sabe a que se puede deber? El log de tomcat no me muestra ningún error.
Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

JSP carga correctamente en Windows pero no en Linux

Publicado por Pedro (7 intervenciones) el 16/07/2015 23:40:55
Hola
Que navegador estas ocupando el rhel?
Puedes hacer una prueba con netbeans en rhel?
Desplegar tu aplicacion en el navegador que estas ocupando ahí.

Estas ocupando un framework en especial? RichFaces, PrimeFaces, Wicket, , Stripes...
Para que mede una idea de que esta sucediendo con tu proyecto.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

JSP carga correctamente en Windows pero no en Linux

Publicado por Oscar (3 intervenciones) el 17/07/2015 00:05:36
Hola,
Te comento la aplicación está desplegado en un servidor RHEL, pero yo accedo vía web desde un cliente que es una PC con Windows 7 y navegador Chrome (el mismo que utilizo cuando lo pruebo con Netbeans desde la PC). No utilizo el navegador del servidor ya que no tiene.

Mi ambiente de desarrollo es mi PC con windows 7 y acceso a la app desde Chrome. Cuando lo coloco en RHEL, accedo via web desde mi PC cliente igual con Chrome.

No utilizo ningún framework, solo JSP puro y JDBC. Lo raro es que tengo otras JSP que cargan muchos mas datos y aparecen completas, solo tengo problemas con ésta cuando está desplegada en RHEL.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

JSP carga correctamente en Windows pero no en Linux

Publicado por Pedro (7 intervenciones) el 17/07/2015 02:10:42
Hola



Ya me dejaste confundido!!!
Entonces en donde no se muestra correctamente la página web?, si la estas desarrollando en windows y testeando con chrome.

Tienes las mismas versiones del navegador en el windows y en la pc con gnu/linux.
El jdk o jre que tienes en el servidor y en la pc que no te aparece bien la pagina son los mismos.

No si si puedas mostrar la parte del código donde se esta presentando el error, para poderte ayudar un poco más.
Si no se puede déjame investigarte con mis colegas para ver si te podemos ayudar.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

JSP carga correctamente en Windows pero no en Linux

Publicado por Oscar (3 intervenciones) el 17/07/2015 03:11:13
Hola,
Tengo una pc windows 7 que uso como ambiente de desarrollo. Aca tengo netbeans y testeo con chrome. Ejecuta correctamente la aplicacion.

Cuando el war lo paso al rhel, accedo a la aplicacion desde la pc mencionada anteriormente via chrome. Pero en este caso el segundo form se me muestra incompleto,

Mañana coloco el codigo del segundo jsp.
Gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar