Java - Problemas con version de java

   
Vista:

Problemas con version de java

Publicado por David (4 intervenciones) el 21/09/2007 18:46:29
tengo este problema a la hora de querer levantar una pag. quisiera saber si tengo que utilizar una version mas nueva o una mas vieja a la que estoy utilizando

java.lang.UnsupportedClassVersionError: org/biojava/servlets/dazzle/DazzleServlet (Unsupported major.minor version 50.0)
java.lang.ClassLoader.defineClass0(Native Method)
java.lang.ClassLoader.defineClass(ClassLoader.java:502)
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:1634)
org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:860)
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1307)
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1189)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:118)
org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:799)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:705)
org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:577)
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
java.lang.Thread.run(Thread.java:536)
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problemas con version de java

Publicado por Victor Oliva (66 intervenciones) el 21/09/2007 22:21:26
Hola David,

que version de Java tienes y que version de Apache Tomcat estas utilizando o Jboss en su defecto.???? Si respondes eso te podremos ayudar un poco más.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con version de java

Publicado por chuidiang (949 intervenciones) el 22/09/2007 14:10:43
Hola:

Ese error sale cuando ejecutas con un java viejo unos .jar o .class que han sido compilados con un java más moderno.

La solución es compilar con un java más viejo o bien ejecutar con un java más nuevo.

El caso contrario no suele dar problemas, ya que normalmente un java nuevo es capaz de ejecutar código compilado con un java viejo.

Se bueno.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con version de java

Publicado por David (4 intervenciones) el 24/09/2007 03:11:44
la version de java es la 1.4 y el tomcat es el 5
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar