Código de Pseudocódigo/Diagramas de Flujo - Obtener los dos mayores y los dos menores números introducidos

<<>>
Imágen de perfil

Obtener los dos mayores y los dos menores números introducidosgráfica de visualizaciones


Pseudocódigo/Diagramas de Flujo

Publicado el 16 de Agosto del 2020 por Administrador (692 códigos)
498 visualizaciones desde el 16 de Agosto del 2020
Dada una lista de n números naturales introducidos por el usuario, se pide:
- Determinar el mayor y menor número de dicha lista.
- Determinar los dos mayores y los dos menores números de dicha lista.

No se sabe cuántos números existen en dicha lista por lo que deberá leerlos uno a uno. El flujo de lectura terminará cuando se lea un número menor que cero. En ese caso, no se debe considerar este número como parte de la lista.

Requerimientos

PSeInt

20200504

Publicado el 16 de Agosto del 2020gráfica de visualizaciones de la versión: 20200504
499 visualizaciones desde el 16 de Agosto del 2020
estrellaestrellaestrellaestrellaestrella
estrellaestrellaestrellaestrella
estrellaestrellaestrella
estrellaestrella
estrella


Forma parte de Mayores y menores de un conjunto de números en PSeInt
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
//Creado por Andrés Melgar
//para iterando++ http://iterando.online/
//entrada: http://iterando.online/ejercicios-resueltos/mayores-y-menores-de-un-conjunto-de-numeros-en-pseint/
Algoritmo Mayores_y_menores
	i<-0
	Repetir
		Escribir "Ingrese número ", i+1, ": "
		Leer n
		Si n>=0 Entonces
			i<-i+1
			Si i=1 Entonces
				mayor_magnitud1 <- n
				menor_magnitud1 <- n
			SiNo
				Si i=2 o n>mayor_magnitud1 o n>mayor_magnitud2 Entonces
					Si n>mayor_magnitud1 Entonces
						mayor_magnitud2<- mayor_magnitud1
						mayor_magnitud1 <- n
					SiNo
						mayor_magnitud2 <- n
					FinSi
				FinSi
				Si i=2 o n<menor_magnitud1 o n<menor_magnitud2 Entonces
					Si n<menor_magnitud1 Entonces
						menor_magnitud2<- menor_magnitud1
						menor_magnitud1 <- n
					SiNo
						menor_magnitud2 <- n
					FinSi
				FinSi
			FinSi
		FinSi
	Mientras Que n>=0
	Si i=0 Entonces
		Escribir "No se ha ingresado ningún número"
	SiNo
		Escribir "El 1er número con mayor magnitud es: ", mayor_magnitud1
		Si i>=2 Entonces
			Escribir "El 2do número con mayor magnitud es: ", mayor_magnitud2
		FinSi
		Escribir "El 1er con menor magnitud es: ", menor_magnitud1
		Si i>=2 Entonces
			Escribir "El 2do con menor magnitud es: ", menor_magnitud2
		FinSi
	FinSi
FinAlgoritmo



Comentarios sobre la versión: 20200504 (0)


No hay comentarios
 

Comentar la versión: 20200504

Nombre
Correo (no se visualiza en la web)
Valoración
Comentarios...
CerrarCerrar
CerrarCerrar
Cerrar

Tienes que ser un usuario registrado para poder insertar imágenes, archivos y/o videos.

Puedes registrarte o validarte desde aquí.

Codigo
Negrita
Subrayado
Tachado
Cursiva
Insertar enlace
Imagen externa
Emoticon
Tabular
Centrar
Titulo
Linea
Disminuir
Aumentar
Vista preliminar
sonreir
dientes
lengua
guiño
enfadado
confundido
llorar
avergonzado
sorprendido
triste
sol
estrella
jarra
camara
taza de cafe
email
beso
bombilla
amor
mal
bien
Es necesario revisar y aceptar las políticas de privacidad

http://lwp-l.com/s6418