Código de Pseudocódigo/Diagramas de Flujo - Crear un array multidimensional con un tamaño definido y llenarlo de numeros aleatorios

Imágen de perfil
Crea un arreglo o array multidimensional con un tamaño que nosotros le indiquemos por teclado (puede ser 6×4, 7×2, etc.), recorre el array o arreglo e introduce número aleatorios (función azar(x) donde x es el limite donde generara), crea una función llamada rellenaArray.
Por último, muestralos por pantalla tal como quedarían en el array o arreglo

pseint-array-mutidimensional

Requerimientos

PSeInt

20180110

Publicado el 22 de Octubre del 2019gráfica de visualizaciones de la versión: 20180110
1.067 visualizaciones desde el 22 de Octubre del 2019
estrellaestrellaestrellaestrellaestrella
estrellaestrellaestrellaestrella
estrellaestrellaestrella
estrellaestrella
estrella


Forma parte de DDR
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
SubProceso rellenaArray ( num, FILAS, COLUMNAS )
 
    Para i<-1 Hasta FILAS Con Paso 1 Hacer
        Para j<-1 Hasta COLUMNAS Con Paso 1 Hacer
            //Genera numeros entre 0 y 9
            num[i,j]<-azar(10)
        Fin Para
    Fin Para
Fin SubProceso
 
SubProceso  mostrarArray ( num, FILAS, COLUMNAS)
    Para i<-1 Hasta FILAS Con Paso 1 Hacer
        Para j<-1 Hasta COLUMNAS Con Paso 1 Hacer
            escribir num[i,j]," " Sin Saltar
        Fin Para
        //Salto de linea
        escribir ""
    Fin Para
Fin SubProceso
 
Proceso Ejercicio7
 
    //Declaramos variables  
    Definir num como entero
    Definir FILAS como entero
    Definir COLUMNAS Como Entero
 
    //Definimos las filas y columnas del array por teclado
    escribir "Introduce las filas del array"
    leer FILAS
 
    escribir "Introduce las columnas del array"
    leer COLUMNAS
 
    //Definimos el array
    Dimension num[FILAS, COLUMNAS]
 
    //Invocamos la función  
    rellenaArray(num, FILAS, COLUMNAS)
    mostrarArray( num, FILAS, COLUMNAS)
 
FinProceso



Comentarios sobre la versión: 20180110 (0)


No hay comentarios
 

Comentar la versión: 20180110

Nombre
Correo (no se visualiza en la web)
Valoración
Comentarios...
CerrarCerrar
CerrarCerrar
Cerrar

Tienes que ser un usuario registrado para poder insertar imágenes, archivos y/o videos.

Puedes registrarte o validarte desde aquí.

Codigo
Negrita
Subrayado
Tachado
Cursiva
Insertar enlace
Imagen externa
Emoticon
Tabular
Centrar
Titulo
Linea
Disminuir
Aumentar
Vista preliminar
sonreir
dientes
lengua
guiño
enfadado
confundido
llorar
avergonzado
sorprendido
triste
sol
estrella
jarra
camara
taza de cafe
email
beso
bombilla
amor
mal
bien
Es necesario revisar y aceptar las políticas de privacidad

http://lwp-l.com/s5599