Código de Pseudocódigo/Diagramas de Flujo - Tabla de multiplicar del 1 al 9

Imágen de perfil

Tabla de multiplicar del 1 al 9gráfica de visualizaciones


Pseudocódigo/Diagramas de Flujo

Publicado el 27 de Octubre del 2019 por Administrador
508 visualizaciones desde el 27 de Octubre del 2019
Crea un array o arreglo multidimensional que contenga la tabla de multiplicar del 1 al 9 (10 filas y 10 columnas).

tabla-multiplicar-pseint

Requerimientos

PSeInt

20180110

Publicado el 27 de Octubre del 2019gráfica de visualizaciones de la versión: 20180110
509 visualizaciones desde el 27 de Octubre del 2019
estrellaestrellaestrellaestrellaestrella
estrellaestrellaestrellaestrella
estrellaestrellaestrella
estrellaestrella
estrella


Forma parte de DDR
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
SubProceso calculaTabla ( tabla_multiplicar, FILAS, COLUMNAS )
 
    Para i<-2 Hasta FILAS Con Paso 1 Hacer
        Para j<-2 Hasta COLUMNAS Con Paso 1 Hacer
            //Empezamos desde la posicion 2,2
            //Lo único que varia es la fila o la columna en cada caso
            tabla_multiplicar[i,j]<-tabla_multiplicar[i,1]*tabla_multiplicar[1,j]
        Fin Para
    Fin Para
 
Fin SubProceso
 
SubProceso rellenaColumnasPrinc ( tabla_multiplicar, FILAS)
 
    definir contador como entero
    contador<-0
 
    Para i<-1 Hasta FILAS Con Paso 1 Hacer
        tabla_multiplicar[1,i]<-contador
        tabla_multiplicar[i,1]<-contador
        contador<-contador+1
    Fin Para
 
Fin SubProceso
 
SubProceso  mostrarArray ( tabla_multiplicar, FILAS, COLUMNAS)
 
    Para i<-1 Hasta FILAS Con Paso 1 Hacer
        Para j<-1 Hasta COLUMNAS Con Paso 1 Hacer
            escribir tabla_multiplicar[i,j]," " Sin Saltar
        Fin Para
        //Salto de linea
        escribir ""
    Fin Para
 
Fin SubProceso
 
Proceso Ejercicio10
 
    //Definimos las variables   
    definir FILAS como entero
    definir COLUMNAS como entero
    FILAS<-10
    COLUMNAS<-10
    dimension tabla_multiplicar[FILAS,COLUMNAS]
 
    //Funciones 
    rellenaColumnasPrinc(tabla_multiplicar, FILAS)
    calculaTabla(tabla_multiplicar, FILAS, COLUMNAS )
    mostrarArray(tabla_multiplicar, FILAS, COLUMNAS)
 
FinProceso



Comentarios sobre la versión: 20180110 (0)


No hay comentarios
 

Comentar la versión: 20180110

Nombre
Correo (no se visualiza en la web)
Valoración
Comentarios
Es necesario revisar y aceptar las políticas de privacidad

http://lwp-l.com/s5609